Results 1 to 5 of 5

Thread: Theme problem in QT applications

  1. #1
    Join Date
    Jan 2007
    Location
    Bogota, Colombia
    Beans
    49
    Distro
    Ubuntu Development Release

    Question Theme problem in QT applications

    Hi guys, yesterday I made an upgrade to 13.04 from 12.10, I got a problem today with Compiz and libunityshell.so, so I removed (and purge) almost all applications (compiz, unity and beyond... firefox, chrome, libreoffice, lightdm)...

    After that I reinstalled all the applications (ubuntu-desktop) and now it is working fine everything (BTW Ubuntu 13.04 is really fast )

    But now I have a problem with some apps (qt apps) like qbittorrent, VirtualBox, etc. All of them looks weird and with KDE icons... When I installed all this applications they just works using the GTK theme, but now they looks ugly.

    Do you know how can I recover this aspect? I already tried using qtconfig-qt4 (as normal user and as sudo) but that didn't work.


    Attached is an image from one dialog window in qBittorrent.
    Attached Images Attached Images

  2. #2
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Theme problem in QT applications

    I see the same thing here.
    Attached Images Attached Images

  3. #3
    Join Date
    Jun 2007
    Beans
    13,178

    Re: Theme problem in QT applications

    There was an issue seen here a few weeks ago in an ubuntu session, (ambiance theme) with qt4, may or may not be your issue
    (I only saw on installs of recent history, mid Dec or so thru now.

    resolved by installing libgnome2-common or editing a certain schema file
    So it wouldn't hurt to try -
    Code:
    sudo apt-get install libgnome2-common
    (& maybe a log out/in
    Last edited by mc4man; January 21st, 2013 at 02:37 AM. Reason: (&

  4. #4
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Theme problem in QT applications

    Quote Originally Posted by mc4man View Post
    There was an issue seen here a few weeks ago in an ubuntu session, (ambiance theme) with qt4, may or may not be your issue
    (I only saw on installs of recent history, mid Dec or so thru now.

    resolved by installing libgnome2-common or editing a certain schema file
    So it wouldn't hurt to try -
    Code:
    sudo apt-get install libgnome2-common
    (& maybe a log out/in
    Thanks mc4man, that fixed it for me.

  5. #5
    Join Date
    Jun 2007
    Beans
    13,178

    Re: Theme problem in QT applications

    Quote Originally Posted by cariboo907 View Post
    that fixed it for me.
    Here's the bug on, qt4(x11) issues generally take their time being resolved
    https://bugs.launchpad.net/ubuntu/+s...1/+bug/1094360

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •