Results 1 to 5 of 5

Thread: No sounds mixer controls in Unity

  1. #1
    Join Date
    Sep 2010
    Beans
    26

    No sounds mixer controls in Unity

    Since I installed 13.04 I have not had a working sound mixer in Unity, the mixer exists but it does not see a sound device so the controls don't work. I have been having to use AlsaMixer. Is this a common issue (search didn't find anything)? Can anyone point me in the right direction to fix it?

    Thanks much.

  2. #2
    Join Date
    Sep 2011
    Beans
    43
    Distro
    Ubuntu Development Release

    Re: No sounds mixer controls in Unity

    Try:
    sudo apt-get install --reinstall pulseaudio
    sudo reboot

  3. #3
    Join Date
    Oct 2008
    Location
    ExodusHair<Čubura
    Beans
    3,853
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: No sounds mixer controls in Unity

    Quote Originally Posted by MadNachos View Post
    Since I installed 13.04 I have not had a working sound mixer in Unity, the mixer exists but it does not see a sound device so the controls don't work. I have been having to use AlsaMixer. Is this a common issue (search didn't find anything)? Can anyone point me in the right direction to fix it?

    Thanks much.
    Did You try using pavucontrol to configure PulseAudio...?
    Quote Originally Posted by anca-emanuel View Post
    Try:
    sudo apt-get install --reinstall pulseaudio
    sudo reboot
    Big hammer approach...
    Reboot is not necessary, PA can be restarted nicely... But even reinstall, I think is not necessary... Just tuning...

  4. #4
    Join Date
    Sep 2010
    Beans
    26

    Re: No sounds mixer controls in Unity

    Quote Originally Posted by anca-emanuel View Post
    Try:
    sudo apt-get install --reinstall pulseaudio
    sudo reboot
    No dice.

  5. #5
    Join Date
    Sep 2010
    Beans
    26

    Re: No sounds mixer controls in Unity

    Quote Originally Posted by zika View Post
    Did You try using pavucontrol to configure PulseAudio...?
    Big hammer approach...
    Reboot is not necessary, PA can be restarted nicely... But even reinstall, I think is not necessary... Just tuning...
    I have never used pavucontrol but I installed it and just ran it and it says 'connection to pulseaudio failed'. So I checked to see if pulse was running and it was not. Running 'pulseaddio' from bash gives me:

    Code:
    W: [pulseaudio] source.c: Default and alternate sample rates are the same.
    E: [pulseaudio] module.c: Failed to open module "module-esound-protocol-unix": file not found
    E: [pulseaudio] main.c: Module load failed.
    E: [pulseaudio] main.c: Failed to initialize daemon.
    So at least I have an idea of where to go next.

    ETA: Looks like installing pulseaudio-esound-compat solved the issue. Others have also had this issue as noted here:

    https://bugs.launchpad.net/ubuntu/+s...o/+bug/1078543
    Last edited by MadNachos; January 21st, 2013 at 04:01 AM. Reason: Added the solution

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •