Page 1 of 4 123 ... LastLast
Results 1 to 10 of 35

Thread: Shrew Soft VPN not in Software Center

  1. #1
    Join Date
    Aug 2012
    Beans
    5

    Question Shrew Soft VPN not in Software Center

    I had Shrew Soft VPN installed on my 12.04 build of Ubuntu. This was great because our VPN configurations file is created with Shrew! I upgraded to 12.10 and it removed my install of Shrew.

    I then did some searching and I found an Ubuntu web page that showed that it should be in the Software Center for 12.10. But it does not exist.

    I went to the Shrew site but for Linux we appear to be treated as third world users as they provide no install files.

    Any suggestions on how to get this back so I can remote into work???

    By the way....pulling down source code, doing my own build, and all that other crap is not a solution.

  2. #2
    Join Date
    Apr 2006
    Location
    Dallas, TX
    Beans
    1,359
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Shrew Soft VPN not in Software Center

    I've never heard of it until now, but the package name is called "ike", and you're right, it isn't in the Quantal repos. The launchpad page for it says something about it being unmaintained?

    https://launchpad.net/ubuntu/quantal/amd64/ike

    Short of reinstalling 12.04, maybe you could try manually downloading the ike, and ike-qtgui, if you need it, debs and installing them?

    http://archive.ubuntu.com/ubuntu/pool/universe/i/ike/

    Actually, just out of curiosity, I downloaded the deb for ike from the above link and it installed without error on my 12.10 system (exact package was "ike_2.1.7+dfsg-1.1_amd64.deb").

    Can't say for sure if it *works* since I don't have a server to connect to, but it does install and starts a daemon...

    BTW, it may not be necessary, but compiling from source doesn't look particularly difficult for this application:

    http://blog.htbaa.com/news/getting-s...ubuntu-to-work

    Good luck

  3. #3
    Join Date
    Jan 2013
    Beans
    14

    Re: Shrew Soft VPN not in Software Center

    Hi there,

    I'm stuck installing this too.. apparently I need a dependency called libqt3 or something.

    But as far as I can tell Qt3 has been superceded by Qt4 (there's no Qt3 in archive.ubuntu.com, only Qt4), and despite there being a "Qt4 with Qt3 support" package available which I have tried, the Shrew compiler doesn't seem to like this at all.

    I always just end up with
    Code:
    -- Could NOT find Qt3 (missing:  QT_QT_LIBRARY QT_INCLUDE_DIR) 
    CMake Error at CMakeLists.txt:423 (message):
      Unable to locate required package : QT
    Can anyone help???

    Thank you!

  4. #4
    Join Date
    Jan 2013
    Beans
    1

    Install Shrew Soft VPN Client On Ubuntu 12.10

    Here's how I was able to install the Shrew Soft client on Ubuntu 12.10

    ----------------------------------------------
    Install Shrew Soft VPN client on Ubuntu 12.10
    Note: If you already have a working Shrew Soft VPN client, use the 'export' feature to export the configuration settings. This file can easily be imported when the new version is up and running.

    *Step 1: download shrew soft package*

    Download the latest linux schrew soft vpn package here: http://www.shrew.net/download/ike

    At the time of writing (01/29/2013) the file is: ike-2.2.0-rc-2.tgz It's not the stable release but works fine as far as I can tell.

    *Step 2: untar package*
    Untar this into a directory and navigate to the folder created called: ike

    *Step 3: try to prepare for install*

    run this command: cmake -DCMAKE_INSTALL_PREFIX=/usr -DQTGUI=YES -DETCDIR=/etc -DNATT=YES

    *Step 4: install dependencies*

    the initial cmake command failed for me the first two times because I needed to install these dependencies:

    libedit
    qt4

    sudo apt-get install libedit-dev
    sudo apt-get install libqt4-core libqt4-dev libqt4-gui

    *Step 5: prepare for installation:*
    Run this command again:
    cmake -DCMAKE_INSTALL_PREFIX=/usr -DQTGUI=YES -DETCDIR=/etc -DNATT=YES

    *Step 6: install the application using this command*

    sudo checkinstall

    *Step 7: launch the shrew soft daemon* sudo iked

    *Step 8: launch the graphical interface*

    sudo qikea

    *Step 9: use the import feature or set up a new connection*


    *Step 10: done*

  5. #5
    Join Date
    Jan 2013
    Beans
    14

    Re: Shrew Soft VPN not in Software Center

    Thank you so much !!

    I hadn't even noticed the beta versions available for download so I had been trying the latest stable release.

    Have just followed your instructions and with the exception of not being able to run 'sudo checkinstall' and using 'sudo make install' instead all it went perfectly and I'm not successfully VPN'd into the office !!

  6. #6
    Join Date
    May 2010
    Beans
    123

    Re: Shrew Soft VPN not in Software Center

    I have almost given up all hope.

    When I run the following command I get this error

    cmake -DCMAKE_INSTALL_PREFIX=/usr -DQTGUI=YES -DETCDIR=/etc -DNATT=YES
    -- Using install prefix /usr ...
    -- Using etc install path /etc ...
    -- Using bin install path /usr/bin ...
    -- Using sbin install path /usr/sbin ...
    -- Using lib install path /usr/lib ...
    -- Using man install path /usr/local/man ...
    CMake Error at CMakeLists.txt:265 (message):
    Unable to locate openssl crypto include files


    Any ideas?
    Last edited by Aydos; February 2nd, 2013 at 04:34 AM.

  7. #7
    Join Date
    Jan 2013
    Beans
    14

    Re: Shrew Soft VPN not in Software Center

    Looks like you need to install OpenSSL, try this:

    Code:
    sudo apt-get install libssl-dev libssl0.9.7
    Last edited by esvcv; February 2nd, 2013 at 09:32 AM. Reason: corrected package name

  8. #8
    Join Date
    May 2010
    Beans
    123

    Re: Shrew Soft VPN not in Software Center

    I tried that and I got this

    sudo apt-get install libssl-dev libssl10.9.7
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package libssl10.9.7
    E: Couldn't find any package by regex 'libssl10.9.7'

  9. #9
    Join Date
    Jan 2013
    Beans
    14

    Re: Shrew Soft VPN not in Software Center

    Sorry that was my mistake, there shouldn't be a 1 in there, try:

    Code:
    sudo apt-get install libssl0.9.7

  10. #10
    Join Date
    May 2010
    Beans
    123

    Re: Shrew Soft VPN not in Software Center

    Well I am still getting this even with the new command

    sudo apt-get install libssl0.9.7
    [sudo] password for -----:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    E: Unable to locate package libssl0.9.7
    E: Couldn't find any package by regex 'libssl0.9.7'

Page 1 of 4 123 ... LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •