Results 1 to 9 of 9

Thread: Unable to Use Deluge - No Incoming Connections

  1. #1
    Join Date
    Dec 2012
    Beans
    3

    Unable to Use Deluge - No Incoming Connections

    I am posting this in the beginners forum because this is my first real experience with Linux and Ubuntu.

    I have two Windows laptops connected to a newly built server running Ubuntu 12.04.1 LTS. I installed Deluge on the server and activated the Web UI on one of the laptops. I set Deluge to automatically connect to any torrent added to one of the shared folders on the server.

    When I attempt to add a torrent, either directly through either the client on the server or the Web UI or by adding the torrent to the designated shared folder, the torrent appears in Deluge, but it won't connect. I can download the same torrent using utorrent on my Windows laptop, so that is not the problem. The status bar states "No Incoming Connections!". I searched for as much information as I could online before posting, but most of what was mentioned did not apply. For instance, UPnP has been enabled on both Deluge and my router.

    I've been working on this for several hours now, but I admit, I'm wandering in the dark here. I am also posting this on the Deluge forum, but similar posts seem to be directed away to forums such as this. Thank you for your assistance. I will be happy to provide any additional information you might find useful.

  2. #2
    Join Date
    Sep 2012
    Beans
    92
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Unable to Use Deluge - No Incoming Connections

    Try to flush the IP tables. I don't remember the code. That was the only way I could manage to download on torrent software in Ubuntu.

    PS: Don't do this if you have set up rules.

  3. #3
    Join Date
    Dec 2012
    Beans
    3

    Re: Unable to Use Deluge - No Incoming Connections

    I flushed the IP tables, but there was no change.

  4. #4
    monkeybrain2012 is offline Grande Half-n-Half Cinnamon Ubuntu
    Join Date
    Oct 2012
    Beans
    874

    Re: Unable to Use Deluge - No Incoming Connections

    I see the warning sometimes, but it never actually impedes downloading or uploading, everything works fine so I kind of ignore it. Moreover, it only happens from time to time.

  5. #5
    Join Date
    Jun 2009
    Location
    Barcelona, Venezuela
    Beans
    12
    Distro
    Ubuntu 11.04 Natty Narwhal

    Unhappy Re: Unable to Use Deluge - No Incoming Connections

    I have a very similar problem: can't download anything since i updated from ubuntu 12.04 32b to ubuntu 12.10 64b. I've tried installing, reinstalling, purging, (you name it) with deluge. Back in 12.04 i had no problem, but now it just wont work.

    Triyng stuff, i installed transmission (had it unistalled when updated), but it wont download either.

    Checked iptables, but there is no rule established, and the policies are set to ACCEPT.

    Then i began thinking that my internet provider was blocking torrents, so i took the 3G modem (all i have for internet connection) and placed it in a laptop (borrowed) with ubuntu 12.04 32b, started deluge with the same torrents and it began downloading: so ruled out blocking by provider. Furthermore, i connected the modem to my PC (the one with 12.10 64b), and used ICS config for my LAN, then connected the laptop to it, and deluge in laptop is still able to download torrents (note that internet traffic goes trough the main PC, which confirms that there is no firewall blocking anything).

    I made the same settings in both deluge's, since the one in the laptop worked, and still nothing.

    So, i ran out of options and still cant get deluge to download anything.

    So please, i really need your help to solve this.


    PS: i went from 12.04 to 12.10 before going from 32b to 64b, and can't say for sure but i think that deluge wasn't working in 12.10 32b either.

  6. #6
    Join Date
    Dec 2012
    Beans
    1

    Re: Unable to Use Deluge - No Incoming Connections

    I have installed/uninstalled/reinstalled Deluge and can not get it to work. The problem is I can't get it to connect to the internet. I have tried numerous things in that area with no success.
    It says no incoming connections at the bottom of the GUI, and going into preferences/network/test active port, and nothing... When I have tried to start a download, it doesn't show up as an option for download.
    I have it installed on another computer and it does a great job. Transmission is okay, but I would rather have Deluge.
    I don't know if processor has anything to do with it, but this computer is 64x and the other computer is a very old 32x.
    Last edited by 420trvlr; December 27th, 2012 at 11:41 PM.

  7. #7
    Join Date
    Dec 2012
    Beans
    3

    Re: Unable to Use Deluge - No Incoming Connections

    As an update, my Internet connection is fine. I also tried using qBitTorrent, but I can't get any torrent to connect with that program either. All of the torrents I have tested download just fine on my Windows computer. It seems that I can't get any torrent application to work in Ubuntu. Any thoughts?

  8. #8
    Join Date
    Dec 2008
    Location
    east coast US
    Beans
    322
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Unable to Use Deluge - No Incoming Connections

    I'm having the same exact problem. If anyone has come across a solution can you point me in the right direction?

  9. #9
    Join Date
    Jan 2013
    Beans
    1

    Re: Unable to Use Deluge - No Incoming Connections

    Also having this problem.

    Can't use any bittorrent client to download torrents. However, my other computers, (windows 8, osx) can use clients.

    Tried three clients, with nothing.

    Using 12.04 LTS

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •