Results 1 to 7 of 7

Thread: Disable screen saver/power management?

  1. #1
    Join Date
    Apr 2008
    Location
    Texas
    Beans
    68
    Distro
    Xubuntu 12.04 Precise Pangolin

    Disable screen saver/power management?

    I just switched over to Xubuntu, and I am running 12.04. I use this laptop to watch movies, but I am having all sorts of media playback issues. When I used Ubuntu (gnome) I used Totem and VLC. There were settings to disable the screen saver, and to start the video from the last position. None of this seems to be possible in Xubuntu. Since I'm new to it, I'm not sure if its something that I am doing wrong.

    I have tried several players but I keep having the same problems. The first problem is the screen saver. I checked the box in Parole that was supposed to deactivate the screen saver, but it still comes on.

    I tried smplayer, same problem. In addition, smplayer seems to have format issues as well. If I select full screen, it extends off the screen and has to be manually resized. Very annoying.

    I tried Totem, as this was the player I used in Ubuntu. The screen saver still comes on.

    I tried VLC, but there is static in the audio. I tried to find the setting to turn off the screen saver, but I cant find one.

    All I want is a simple player that will keep the screen saver from coming on. I would love to be able to edit the keyboard commands (like in VLC), but right now, Ill be happy if I can just watch a video without manually disabling the screen saver.

    Im not sure if this is a power management problem, or a conflict with the screen saver settings. I wasn't sure if I should post this here, or in the Media section, as it seems to involve a few different areas. Any suggestions would be appreciated. Thanks..

  2. #2
    Join Date
    Jul 2011
    Beans
    211

    Re: Disable screen saver/power management?

    I would try the terminal command:

    Code:
    xset -dpms
    To turn power management back on:

    Code:
    xset +dpms

  3. #3
    Join Date
    Apr 2008
    Location
    Texas
    Beans
    68
    Distro
    Xubuntu 12.04 Precise Pangolin

    Re: Disable screen saver/power management?

    Nope. The screen saver still comes on. I have the same problem on my other laptop, but when I installed VLC on it, the screen saver does not come on.

    I just want to watch movies without the screen saver coming on every 5 minutes.

  4. #4
    Join Date
    Feb 2012
    Beans
    27

    Re: Disable screen saver/power management?

    you can disable power management from settings->session and startup

    you can also disable screensaver from settings->screensaver

  5. #5
    Join Date
    Jan 2012
    Beans
    21

    Post Re: Disable screen saver/power management?

    I was trying to figure out almost the same issue her for a Ubuntu 12.04 client which should run 24/7 without any blank or black screen. Maybe my way to fix things can help you, too:

    First of all, I changed a line in /etc/default/grub, in order to switch off power management at all.

    Old:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=force"
    New:
    Code:
    GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi=off"
    After a reboot, the terminal command
    Code:
    dmesg | grep -i ACPI
    informed me that ACPI has been disabled.

    Then I created a new file xset_off.sh in my home directory. Its content is
    Code:
    !#/bin/bash
    exec xset -dpms s 0 0 s noblank s noexpose s off
    (Don't forget to make this file executable with
    Code:
    chmod +x ~/xset_off.sh
    .)

    In order to have this script run everytime when your X window environment is launched, you can either add it to your autostart objects in the GUI desktop. Or you create a new file ~/.config/autostart/xset_off.sh.desktop.

    Mine has the following content (autogenerated by the GUI desktop):

    Code:
    [Desktop Entry]
    Type=Application
    Exec=/home/XXXXXXXX/xset_off.sh
    Hidden=false
    NoDisplay=false
    X-GNOME-Autostart-enabled=true
    Name[de_DE]=xset off
    Name=xset off
    Comment[de_DE]=Bildschirmschoner aus
    Comment=Screen Saver Off
    The next time when you have booted your system, a simple check of the xset parameters with
    Code:
    xset q
    should inform you that both Screen Saver and DPMS have successfully been switched off.

  6. #6
    Join Date
    Dec 2007
    Beans
    6

    Re: Disable screen saver/power management?

    Quote Originally Posted by husnos View Post
    you can disable power management from settings->session and startup

    you can also disable screensaver from settings->screensaver
    In Xubuntu 12.04, display power management can be disabled under settings-->Settings Manager-->Power Manager; uncheck "Monitor power management control"

    That did it for me, anyway. Good luck!

  7. #7
    Join Date
    Dec 2005
    Beans
    18
    Distro
    Ubuntu

    Re: Disable screen saver/power management?

    exec xset -dpms s 0 0 s noblank s noexpose s off

    seams to be the solution in my case, though I have uninstalled the screensaver completely.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •