Quote Originally Posted by jdthood View Post
It's useful to know that this fixed name service, but you should now restore /etc/resolv.conf and fix the problem the right way by setting RESOLVCONF=no in /etc/default/bind9. To restore /etc/resolv.conf, run "sudo dpkg-reconfigure resolvconf", then check to make sure that /etc/resolv.conf is a symbolic link to "../run/resolvconf/resolv.conf".
Okay you see now jdthood I applied the fix you said
Code:
sudo dpkg-reconfigure resolvconf
I then rebooted and the issue came back. Unable to connect to the internet and RESOVCONF is set to NO. in /etc/default/bind9

I also noticed that after reconfiguring Resolvconf all my bind9 issues went away. I can now restart bind without any error codes due to rndc like before
Code:
root@igemonas:~# service bind9 restart
 * Stopping domain name service... bind9                                                                                                                       waiting for pid 1242 to die
                                                                                                                                                        [ OK ]
 * Starting domain name service... bind9                                                                                                                [ OK ] 
root@igemonas:~# ping google.com
ping: unknown host google.com
root@igemonas:~# cat /etc/default/bind9 
# run resolvconf?
RESOLVCONF=no

# startup options for the server
OPTIONS="-u bind"

root@igemonas:~# ping sammojohn.com
PING sammojohn.com (108.92.196.86) 56(84) bytes of data.
64 bytes from igemonas.sammojohn.com (108.92.196.86): icmp_req=1 ttl=64 time=0.030 ms
64 bytes from igemonas.sammojohn.com (108.92.196.86): icmp_req=2 ttl=64 time=0.044 ms
64 bytes from igemonas.sammojohn.com (108.92.196.86): icmp_req=3 ttl=64 time=0.043 ms
^C
--- sammojohn.com ping statistics ---
3 packets transmitted, 3 received, 0% packet loss, time 1998ms
rtt min/avg/max/mdev = 0.030/0.039/0.044/0.006 ms
Also can you please tell me how to check to see if resolv.conf is a symlink to ../run/resolvconf/resolv.conf like you mentioned? Not sure I understand how to do that.