Results 1 to 2 of 2

Thread: Can't write to VBox shared folder Win7 (host) Lubuntu 12.04 (guest)

  1. #1
    Join Date
    Sep 2012
    Beans
    17

    Can't write to VBox shared folder Win7 (host) Lubuntu 12.04 (guest)

    I'm posting here cause I have no idea how can I solve my problem...

    I'm used to make VBox lubuntu (hosts) and WinXP (guests) and had no problem with it so far. Now trying on Win7 host is pissing me off! But I guess the problem is on some config. on linux, cause I guess it was working before, maybe an update (kernel?) might have messing things up!

    Ok, let's go:

    Host: Windows 7 Ultimate
    Client: Ubuntu 12.04
    VM software: VirtualBox
    Guest additions: installed
    Shared directory: C:\trocas
    NTFS folder permissions: Everyone = full control

    I'm mounting the shared folder through /etc/fstab like this:
    Code:
    trocas  /home/lnks/Downloads/   vboxsf  rw,auto,exec,uid=1000,gid=116   0       0
    but also tried with gid=1000 and on /etc/rc.local with the command:
    Code:
    sudo mount -t vboxsf -o rw,exec,auto trocas /home/lnks/Downloads/
    Code:
    groups lnks
    retrurns:
    lnks : vboxsf adm lp dialout fax cdrom floppy tape sudo audio dip www-data video plugdev fuse lpadmin netdev lnks sambashare

    The wierd thing is, I can't grant write permissions to the mounted folder with:
    Code:
    sudo chmod +w Downloads/
    No error is returned, but permissions continue to be:
    dr-xr-xr-x 1 lnks vboxsf 4096 Out 26 17:11 Downloads

    All other /home/lnks/ folders have drwxr-xr-x permissions

    Can't change owner with:
    Code:
    sudo chown root.root Downloads/
    Only with the mounting commands...

    Another thing, I can write with Super User:
    Code:
    sudo mkdir /home/lnks/Downloads/test
    But
    Code:
    mkdir /home/lnks/Downloads/test2
    returns: "permission denied"

    Can list an read all files on ~/Downloads/ and cannot write!

  2. #2
    Join Date
    Sep 2012
    Beans
    17

    Re: Can't write to VBox shared folder Win7 (host) Lubuntu 12.04 (guest)

    Solved using "Auto-mount" option...

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •