I've seen to wrap myself around the axle and don't know what to do.

At some point awhile back I tried to do an upgrade and I had some dependency problems. Spending a fair chunk of time with google and trying some suggestions things went from bad to worse. When I used to run

apt-get install -f

it world generate some errors at the end telling me there were dependency problems. Now when I run it, it tells me

locale: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by locale)
locale: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by locale)
Preconfiguring packages ...
(Reading database ... 328164 files and directories currently installed.)
Preparing to replace libc6:amd64 2.13-20ubuntu5.1 (using .../libc6_2.15-0ubuntu10.3_amd64.deb) ...
De-configuring libc6:i386 ...
locale: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by locale)
locale: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by locale)
Checking for services that may need to be restarted...
Checking init scripts...
Checking for services that may need to be restarted...
Checking init scripts...
/usr/bin/locale: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.15' not found (required by /usr/bin/locale)
/usr/bin/locale: /lib/x86_64-linux-gnu/libc.so.6: version `GLIBC_2.14' not found (required by /usr/bin/locale)

and tells me its configuring libc6 and needs to restart 'cron atd'. I hit return basically see the same messages following by a display that tells me it wants to restart 'cron atd' to I enter return again and it displays:

Errors were encountered while processing:
/var/cache/apt/archives/libc6_2.15-0ubuntu10.3_amd64.deb
/var/cache/apt/archives/libc6_2.15-0ubuntu10.3_i386.deb
E: Sub-process /usr/bin/dpkg returned an error code (1)

and exits.

for grins I tried installing xterm just to see what it would do and I'm getting this:

mjs@blkjack:~$ sudo apt-get install xterm
Reading package lists... Done
Building dependency tree
Reading state information... Done
You might want to run 'apt-get -f install' to correct these:
The following packages have unmet dependencies:
libc6 : Depends: libc-bin (= 2.13-20ubuntu5.1)
libc6:i386 : Depends: libc-bin:i386 (= 2.13-20ubuntu5.1)
libnih-dbus1 : Depends: libnih1 (= 1.0.3-4ubuntu9) but 1.0.3-4ubuntu2 is to be installed
xterm : Depends: libc6 (>= 2.15) but 2.13-20ubuntu5.1 is to be installed
E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).

but of course apt-get -f install doesn't work.

Any and all suggestions will be greatly appreciated

-mark