Results 1 to 4 of 4

Thread: Fatal Python error -- can not do apt-get update anymore

Threaded View

  1. #1
    Join Date
    Jun 2010
    Beans
    9

    Fatal Python error -- can not do apt-get update anymore

    Hi, all

    Tried to upgrade from 12.04 to 12.10 and had power failure in the process.

    Now, apt-get update doe snot work anymore, as there is a problem with one of the basic packages -- python3.2-minimal

    Trying to re-configure it and I am getting:
    Fatal Python error: Py_initialize: Unable to get locale encoding
    EOFError: EOF read where not expected
    Aborted (core dumped)

    This error happens in postinst script of the package.

    Tried to run 'python' and it runs OK and it is python 2.7/
    Running python3 generates error above.

    In fact, this error is generated if run anything that is not a command. For example, "crap" is not a command or program and running it generates same error. So, system is badly broken.

    Any ideas on how to fix it? I am afraid on removing the python3 completely and I believe it will make things worse

    Rudolf
    Last edited by rudolfl; January 1st, 2013 at 12:30 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •