Results 1 to 2 of 2

Thread: TFTP problems

  1. #1
    Join Date
    Dec 2012
    Beans
    4

    TFTP problems

    Hi,

    I am beginner with TFTP protocol in Linux. I have been trying to connect a AM335x EVM Board with my Host to make boot. but first I will like to test my TFTP server.

    The configuration is the next:
    # cat /etc/xinetd.d/tftp

    service tftp
    {
    protocol = udp
    port = 69
    socket_type = dgram
    wait = yes
    user = nobody
    server = /usr/sbin/in.tftpd
    server_args = /tftpboot
    disable = no
    }

    # cat /etc/default/tftpd-hpa

    # /etc/default/tftpd-hpa
    TFTP_USERNAME="tftp"
    TFTP_DIRECTORY="/tftpboot"
    TFTP_ADDRESS="0.0.0.0:69"
    TFTP_OPTIONS="--secure"
    RUN_DAEMON="yes"

    the /tftboot has this files:

    # ls -l /tftpboot/
    insgesamt 3096
    -rwxrwxrwx 1 nobody root 174 Dez 4 14:50 test
    -rwxrwxrwx 1 nobody root 3163680 Dez 7 08:59 uImage-am335x-evm.bin

    However when I like getting locally some file in /tftpboot over TFTP protocol, I obtain that:

    # tftp localhost
    tftp> get uImage-am335x-evm.bin
    Error code 1: File not found
    tftp> quit

    Then I make that I see the /var/log/syslog and it shows:

    Dec 12 15:29:46 sst-virtual-machine tftpd[6987]: tftpd: trying to get file: uImage-am335x-evm.bin
    Dec 12 15:29:46 sst-virtual-machine tftpd[6987]: tftpd: serving file from /srv/tftp

    I am sure that I miss something out, because my configuration I thing that is good. But the files in TFTP protocol is looked in the /svr/tftp. Why can it be happening that?
    Because tftp configuration shows server_args = /tftpboot. I think that the TFTP protocol should search the files in that directory /tftpboot, doesn't it?

    I have not more idea what wrong is, any help would be greatly appreciated.

    -Regards
    Last edited by Breixo L Garcia; December 12th, 2012 at 03:43 PM. Reason: correct mistakes

  2. #2
    Join Date
    Dec 2012
    Beans
    4

    Re: TFTP problems

    Hi,

    I think that I have found the mistake. There is a file /etc/xinetd.d/tftpd with this configuration that overread the tftp configuration I suppose, but I am not sure.

    # cat /etc/xinetd.d/tftpd
    service tftp
    {
    socket_type = dgram
    wait = yes
    user = root
    server = /usr/sbin/in.tftpd
    server_args = -s /srv/tftp
    }

    Why can I do to solve this? Can I erase this file without problems or it is better to reconfigurated that like /etc/xinetd.d/tftp


    service tftp
    {
    protocol = udp
    port = 69
    socket_type = dgram
    wait = yes
    user = nobody
    server = /usr/sbin/in.tftpd
    server_args = /tftpboot
    disable = no
    }

    sorry for this question and the time that We lost in there.

    -Regards

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •