Results 1 to 9 of 9

Thread: Chrome - pepperflash plugin not showing up

  1. #1
    Join Date
    Apr 2008
    Location
    Missoula, MT USA
    Beans
    137
    Distro
    Kubuntu

    Chrome - pepperflash plugin not showing up

    I've had to give up on adobe flash and gnash for my son's PC. Most websites using flash complain that the version of flash installed is too old and won't run.

    So I am trying to use chrome's built in flash but when I go to chrome://plugins, it's not there. Looking in /opt/google/chrome, there is a PepperFlash directory containing libpepflashplayer.so.

    What do I need to do to get pepperflash to show up in plugins so that he can use it?

    Thanks!

  2. #2
    TenPlus1's Avatar
    TenPlus1 is offline Extra Foam Sugar Free Ubuntu
    Join Date
    May 2005
    Location
    Scotland, UK
    Beans
    836
    Distro
    Lubuntu

    Smile Re: Chrome - pepperflash plugin not showing up

    Hrm, if you have the latest version of Google Chrome downloaded and installed then the PepperFlash v11.5 should already be installed and working ok... Are you unning Chromium by any chance ?

  3. #3
    Join Date
    Apr 2008
    Location
    Missoula, MT USA
    Beans
    137
    Distro
    Kubuntu

    Re: Chrome - pepperflash plugin not showing up

    Nope, definitely chrome. Also, I upgraded him to precise about an hour ago. Before the upgrade I did an apt-get remove google-chrome-stable --purge to make sure chrome was completely gone, then reinstalled it after the upgrade was finished.

    Like I said, the .so is there, it just doesn't show up in the plugins page.

  4. #4
    Join Date
    Apr 2008
    Location
    Missoula, MT USA
    Beans
    137
    Distro
    Kubuntu

    Re: Chrome - pepperflash plugin not showing up

    I also removed .config/google-chrome from his home directory to make sure that there was nothing in there that could be fouling things up.
    Last edited by deadtom; December 7th, 2012 at 09:24 PM.

  5. #5
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    5,480
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Chrome - pepperflash plugin not showing up

    Quote Originally Posted by deadtom View Post
    ... when I go to chrome://plugins, it's not there. Looking in /opt/google/chrome, there is a PepperFlash directory containing libpepflashplayer.so.
    ...
    Could you put up a screenshot of the relevant part of chrome://plugins? Also, have you clicked on the + next to details near the top RHS to expand the view?
    de gustibus et coloribus non est disputandum -- Wiktionary

  6. #6
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    5,480
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Chrome - pepperflash plugin not showing up

    Quote Originally Posted by deadtom View Post
    I've had to give up on adobe flash and gnash for my son's PC. Most websites using flash complain that the version of flash installed is too old and won't run.

    So I am trying to use chrome's built in flash but when I go to chrome://plugins, it's not there. Looking in /opt/google/chrome, there is a PepperFlash directory containing libpepflashplayer.so.

    What do I need to do to get pepperflash to show up in plugins so that he can use it?

    Thanks!
    Stupid question but is Flash not working by default? How old is your PC? Specs? There was something that happened around the time of Chrome 19 or 20 after which a lot of oldish hardware didn't work with Pepper Flash.
    de gustibus et coloribus non est disputandum -- Wiktionary

  7. #7
    Join Date
    Apr 2008
    Location
    Missoula, MT USA
    Beans
    137
    Distro
    Kubuntu

    Re: Chrome - pepperflash plugin not showing up

    Yes, I expanded the details. Pepper flash is not listed.

    It is an older PC, maybe 7 or 8 years old.

    AMD Athlon XP 2800+

    Linux 3.2.0-34-generic on i686

    Google Chrome 23.0.1271.95
    Attached Images Attached Images

  8. #8
    Join Date
    Dec 2007
    Location
    Bombay
    Beans
    5,480
    Distro
    Lubuntu 14.04 Trusty Tahr

    Re: Chrome - pepperflash plugin not showing up

    It's just possible that the pepper flash has been disabled on your computer and that there maybe nothing you can do about it. See
    comment #17
    Based on the details so far, it's looking like an issue with older CPUs, possibly ones that don't support sse2 instructions. The Pepper Flash plugin probably won't support such systems, and we may just have to disable it if the necessary CPU capabilities aren't detected.
    and
    comment #57:
    Merge 145632 to M20 - Disable bundled PPAPI Flash on Linux ia32 when SSE2 is not available.
    Then there's comment #77
    Some of the affected cpus are:
    It seems that most of these issues are being generated by SSE2 unsupported cpus.
    Intel Pentium III Coppermine
    Intel Pentium III Tualatin
    Intel Celeron Mendocino
    Intel Celeron Coppermine-128
    Intel Celeron Tualatin-256
    Intel Pentium M
    AMD Athlon XP
    I don't know of a way to verify what your cpu is but this lengthy bug is where I saw the quoted stuff: http://code.google.com/p/chromium/is...tail?id=134940
    de gustibus et coloribus non est disputandum -- Wiktionary

  9. #9
    Join Date
    Apr 2008
    Location
    Missoula, MT USA
    Beans
    137
    Distro
    Kubuntu

    Re: Chrome - pepperflash plugin not showing up

    Well I guess it's finally time to upgrade him then. I think I've stretched that hardware about as far as it's going to go.

    Thanks for all the responses guys!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •