Results 1 to 4 of 4

Thread: JACK/Qsynth/Rosegarden - Output to Soundcard

Threaded View

  1. #1
    Join Date
    Dec 2010
    Location
    Bristol, UK
    Beans
    Hidden!
    Distro
    Ubuntu 12.10 Quantal Quetzal

    JACK/Qsynth/Rosegarden - Output to Soundcard

    Hi,

    I'm running Rosegarden to play a MIDI soundfont (using and electronic drum kit to trigger the notes). I'm using QJackCtrl and Qsynth.

    I can trigger the notes and get sound from my laptop.

    The problem I'm having is that I can't output the sound through my USB-soundcard (Alesis iO|2 audio/MIDI interface). It's the same interface that the MIDI is coming through.

    Sound works fine coming solely out of the interface when I play a .wav in audacity. So it's just a case of switching a connection around I'm sure.

    I tried both setting the interface to hw:1 (labelled as iO|2) and to hw:1,0 (labelled as USB Audio - which is what is listed in Audacity) in QJackCtrl's Setup. It still plays from the laptop...and yes, I did restart QJackCtrl.

    Under QJackCtrl's Connections window, iO|2 doesn't appear to be listed under 'Audio'. It is listed under ALSA but is unconnected on both the input and output side. I've tried connecting it there but it just cuts the sound out entirely.

    I can't seem to find any relevant audio output settings in Rosegarden. I assume that they wouldn't be there because it doesn't make sound on its own anyway?

    Really, I don't know where to look. Any ideas?

    Thanks in advance,

    Vid


    EDIT: I've just discovered that I still get sound (through the laptop speakers) even when QJackCtrl isn't running. This suggests to me that my QJackCtrl settings are not having an effect anyway. Is that right? How can I connect Qsynth/Rosegarden to QJackCtrl?

    Or, how can I modify the settings without using QJackCtrl?


    EDIT #2:

    I tried installing Patchage to connect there. The iO2 soundcard comes up as 4 (green) ALSA based MIDI channels - In, out, Through and another Through. Nothing is (red) Jack controlled MIDI. The only (blue) audio connections are qsynth, system playback and system record.

    What I think is happening is the connection is automatically being made via ALSA to the first available audio output. Which is my laptop's HDA internal soundcard.

    I can't find anywhere to select the iO2 - except for QJackCtrl, which doesn't seem to be connecting. Is there a way to change priority for ALSA? Would that be the best way to do it?
    Last edited by vidwarren; December 7th, 2012 at 11:42 PM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •