Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Missing gstreamer plug-in v4lsrc in Ubuntu 12.04

  1. #1
    Join Date
    Jul 2012
    Beans
    2

    Missing gstreamer plug-in v4lsrc in Ubuntu 12.04

    I am running Ubuntu 12.04.

    Trying to connect a Micro Innovations IC 50C web cam to Skype, but getting just noise instead of a picture.

    Tried running cheese, same result.

    Tried running gstreamer, same result.

    After reading the Ubuntu forums and the Ubuntu Wiki about webcam setup and doing a bit of Google search, it seems that since I have an older webcam, I need the v4lsrc plug-in for gstreamer to be able to decode the picture correctly.


    Using gstreamer-tools, I found that the v4l2src plug-in is present but not the v4lsrc. Running gstreamer-properties also displays a message saying that v4lsrc is missing.


    $ gstreamer-properties
    (gstreamer-properties:11947): Gtk-WARNING **: Unknown property: GtkDialog.has-separator
    (gstreamer-properties:11947): Gtk-WARNING **: Unknown property: GtkDialog.has-separator
    gstreamer-properties-Message: Skipping unavailable plugin 'artsdsink'
    gstreamer-properties-Message: Skipping unavailable plugin 'esdsink'
    gstreamer-properties-Message: Skipping unavailable plugin 'sunaudiosink'
    gstreamer-properties-Message: Skipping unavailable plugin 'glimagesink'
    gstreamer-properties-Message: Skipping unavailable plugin 'sdlvideosink'
    gstreamer-properties-Message: Skipping unavailable plugin 'v4lmjpegsrc'
    gstreamer-properties-Message: Skipping unavailable plugin 'qcamsrc'
    gstreamer-properties-Message: Skipping unavailable plugin 'v4lsrc'
    gstreamer-properties-Message: Skipping unavailable plugin 'esdmon'
    gstreamer-properties-Message: Skipping unavailable plugin 'sunaudiosrc'

    I have double checked that I have all the gstreamer plugins - base, good, bad, etc. gstreamer0.10-gconf is already the newest version. I have gstreamer.0.10.36 for i386.

    Has this plug-in been dropped from the Ubuntu 12.04 gstreamer base plug-ins package? According to the gstreamer website, it is supposed to be included in the gstreamer base plug-in package.

    Could there be any other reason why this plug-in would be reported as missing?

    Thanks a lot for your help.
    Attached Images Attached Images
    Last edited by mightylion; July 23rd, 2012 at 09:03 AM. Reason: Added screenshot attachment.

  2. #2
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Missing gstreamer plug-in v4lsrc in Ubuntu 12.04

    https://help.ubuntu.com/community/We...roubleshooting

    LD_PRELOAD=/usr/lib/libv4l/v4l1compat.so /usr/bin/skype

    Could be a new skype (4.0?) with this fixed & more..or did the purchase by microsoft put an end to it?
    The new skype service/servers do not look very secure from a privacy/espionage viewpoint.
    Last edited by BicyclerBoy; July 23rd, 2012 at 10:55 PM.

  3. #3
    Join Date
    Jul 2012
    Beans
    2

    Re: Missing gstreamer plug-in v4lsrc in Ubuntu 12.04

    Thanks for the reply. That did not work either. Produces the same noise and static as the screenshot I had posted.

  4. #4
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Missing gstreamer plug-in v4lsrc in Ubuntu 12.04

    Assuming you used a terminal to launch skype (with the LD_PRELOAD etc)..
    Post the std output errors from the terminal..

  5. #5
    Join Date
    Sep 2007
    Location
    Thurgoona, NSW, Australia
    Beans
    221
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Missing gstreamer plug-in v4lsrc in Ubuntu 12.04

    Getting exactly the same issue with a Logitech webcam and gstreamer too - did you find a solution or a workaround??
    Thanks.

  6. #6
    Join Date
    Feb 2009
    Beans
    15

    Re: Missing gstreamer plug-in v4lsrc in Ubuntu 12.04

    Hi guys,

    Did anybody find a solution? I am also having this problem now.

    Thanks!!

  7. #7
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Missing gstreamer plug-in v4lsrc in Ubuntu 12.04

    from terminal run:
    gstreamer-properties

    select <video> tab
    click on the plugin drop down selector...

    Is the "Video for linux (1) (v4l1)" missing ?

    It is missing here..

  8. #8
    Join Date
    Sep 2007
    Location
    Thurgoona, NSW, Australia
    Beans
    221
    Distro
    Ubuntu 14.10 Utopic Unicorn

    Re: Missing gstreamer plug-in v4lsrc in Ubuntu 12.04

    Yep, missing here too.

    Reports Video for Linux 2 (v4l2)

  9. #9
    Join Date
    Nov 2006
    Beans
    130
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Missing gstreamer plug-in v4lsrc in Ubuntu 12.04

    Did anyone work this out? I'm having a similar issue.

  10. #10
    Join Date
    Apr 2009
    Location
    Aotearoha
    Beans
    2,661
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Missing gstreamer plug-in v4lsrc in Ubuntu 12.04

    V4l1 was marked for removal in 2010. Drivers were meant to be rebuilt before then.

    The repos package "libv4l-0" is meant to provide:
    libv4l is a collection of libraries which adds a thin abstraction layer on
    top of video4linux2 devices. The purpose of this (thin) layer is to make it
    easy for application writers to support a wide variety of devices without
    having to write separate code for different devices in the same class. libv4l
    consists of 3 different libraries: libv4lconvert, libv4l1 and libv4l2.

    libv4l1 offers the (deprecated) v4l1 API on top of v4l2 devices, independent
    of the drivers for those devices supporting v4l1 compatibility (which many
    v4l2 drivers do not).

    libv4l2 offers the v4l2 API on top of v4l2 devices, while adding for the
    application transparent libv4lconvert conversion where necessary.
    That reads as if the v4l1 compatibility is to do with supporting v4l1 abi applications interfacing with v4l2 driver layer..

    The problem faced by posters in this thread is their v4l2 h/w driver does not work.

    If you build v4l-dvb from source you get a v4l1 compatibility library.
    http://git.linuxtv.org/media_build.git
    I do not have any h/w requiring the old v4l1 api so don't know if it is a soln..

    Note you have to rebuild this after every kernel update..
    Last edited by BicyclerBoy; February 24th, 2013 at 01:48 AM.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •