Results 1 to 6 of 6

Thread: Upgrade minidlna package

  1. #1
    Join Date
    May 2012
    Beans
    3

    Question Upgrade minidlna package

    Hi, I've really tried to brows the web for help but I can't find any info that is helping me to complete my task.

    What I would like to do is to upgrade minidlna on my ubuntu server 12.04 LTS. The current version installed is 1.0.21, and it came when I typed
    Code:
    sudo apt-get install minidlna
    .

    But this is an old version of minidlna and the latest one is 1.0.25.

    Question #1
    Why does not Ubuntu upgrade to 1.0.25 version

    Question #2
    Is there a way for me to upgrade minidlna with
    Code:
    sudo apt-get update
    and
    Code:
    sudo apt-get upgrade
    If so, how can i make Ubuntu understand that tere is an update for minidlna?

    Question #3
    I also tried to install a .patch file for minidlna, but I don't know where the files are that I want to patch. Are these files that I want to patch on my server even though I used
    Code:
    sudo apt-get install minidlna
    I guess you can tell that I'm quite new to Linux so please keep it as easy to understand as possible with good code examples and tips.

    Thanks in advance!
    Last edited by Shutterstrom; November 18th, 2012 at 09:30 PM.

  2. #2
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,827
    Distro
    Ubuntu Development Release

    Re: Upgrade minidlna package

    Hi
    Providing an upgrade to a specific software is not a big deal , though its not such easy thing . Anything you'd like to install can be fine if you satisfied all required dependencies with the specific versions requirements.

    you can have your desired version for sure . get the version source package from its source site and you can install it manually .

    But for manually installed packages/applications Ubuntu not going to provide any updates . so you are at your own risk .

    Hope that helps.
    Raja

    రాజ శేఖర్ రెడ్డి

  3. #3
    Join Date
    May 2012
    Beans
    3

    Question Re: Upgrade minidlna package

    Quote Originally Posted by raja.genupula View Post
    Hi
    Providing an upgrade to a specific software is not a big deal , though its not such easy thing . Anything you'd like to install can be fine if you satisfied all required dependencies with the specific versions requirements.

    you can have your desired version for sure . get the version source package from its source site and you can install it manually .

    But for manually installed packages/applications Ubuntu not going to provide any updates . so you are at your own risk .

    Hope that helps.
    Hi Raja and thanks for the reply.

    What I'm looking for is a way for Ubuntu tu understand that there is an update for minidlna by using the apg-get commando. Is there a way to do that? (refering to my question #2)

    If I download the minidlna_1.0.25_src.tar.gz from sourceforge.net, this means that I will install it manually and will not be able to upgrade minidlna via apt-get in the future?

    If it's possible to upgrade minidlna via apt-get commando, how can I do that then?

  4. #4
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,827
    Distro
    Ubuntu Development Release

    Re: Upgrade minidlna package

    yes thats what i mean . If you have install it manually then in future you can't update with apt-get .

    wait for some more time , I am sure Ubuntu will provide it with next updates . There might be some serious bugs associated with the latest version .

    wait for some more time .

    else in the launchpad page of that pkg you can see whose maintaining it and you can contact the maintainer about the update .

    Hope that helps .
    Raja

    రాజ శేఖర్ రెడ్డి

  5. #5
    Join Date
    Mar 2006
    Beans
    8,335

    Re: Upgrade minidlna package

    Yuo can add this PPA.Version is 1.0.24.
    There is no greater religion than a truth.

  6. #6
    Join Date
    Jan 2009
    Location
    Vancouver
    Beans
    27

    Re: Upgrade minidlna package

    please check this bug
    https://bugs.launchpad.net/ubuntu/+s...a/+bug/1026550

    also I just update via PPA from previous post (https://launchpad.net/~flexiondotorg...e/server-stuff)

    looks fine (1.0.24)
    make sure you backup you config file

    funny enough Ubuntu 12.10 comes with 1.0.24 as already.

    cheers

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •