I'm currently running Ubuntu 11.10 and have tried to upgrade to 12.04. When I do i get the following message:
"Could not calculate the upgrade

An unresolvable problem occurred while calculating the upgrade:
The package 'ubuntu-desktop-boulder' is marked for removal but it is in the removal blacklist.

This can be caused by:
* Upgrading to a pre-release version of Ubuntu
* Running the current pre-release version of Ubuntu
* Unofficial software packages not provided by Ubuntu

If none of this applies, then please report this bug using the command 'ubuntu-bug update-manager' in a terminal."

As far as I know none of the causes applies, except perhaps the third (I have VirtualBox installed). How do I resolve this??