Results 1 to 10 of 29

Thread: cat Japanese text file

Threaded View

  1. #1
    Join Date
    May 2012
    Location
    ザ・ワ&
    Beans
    152
    Distro
    Xubuntu 12.04 Precise Pangolin

    cat Japanese text file

    When I ls the contents of a directory with Japanese filenames it works perfectly fine,
    Code:
    ls
    $read            oto.ini      あ_wav.frq    え.wav
    Mattithyahu.bmp  readme.txt   い.wav        え_wav.frq
    New Project.ust  あ.wav        い.wav.uspec  ゆ.wav
    character.txt    あ.wav.uspec  い_wav.frq    ゆ_wav.frq
    but when I cat a text file with Japanese characters (the very same ones) it gives me these replacement characters.
    Code:
    cat oto.ini
    ��.wav=a,0,0,0,0,0
    ��.wav=i,0,0,0,0,0
    ��.wav=e,0,0,0,0,0
    ��.wav=yu,0,0,0,0,0
    I tried setting the language to Japanese (have to do this with a few of my programs) but it still gives me the same results.
    Code:
    LANG=ja_JP.utf8 cat oto.ini
    ��.wav=a,0,0,0,0,0
    ��.wav=i,0,0,0,0,0
    ��.wav=e,0,0,0,0,0
    ��.wav=yu,0,0,0,0,0
    It *should* read as
    Code:
    あ.wav=a,0,0,0,0,0
    い.wav=i,0,0,0,0,0
    え.wav=e,0,0,0,0,0
    ゆ.wav=yu,0,0,0,0,0
    Does anyone know how to fix this issue?

    Last edited by ntzrmtthihu777; November 18th, 2012 at 09:39 PM. Reason: misplaced [CODE][/CODE] tags

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •