I think you need to look for a simple solution:


Right click on the network applet icon and toggle(turn off and on) 'Enable Networking', 'Enable Wireless' and 'Enable Notifications'. Make sure you have them all ticked. If you've had a failed suspend then they can untick themselves.

Still no wifi?
Check you have the correct user settings: Go to System -> Administration -> Users and Groups -> Advanced Settings -> User Privileges
Make sure "Connect to wireless and ethernet networks" is ticked. This will add your user to the netdev group. You will need to reboot for this to take effect. Note, it is not always necessary to join the netdev group.