Now that is odd. Or maybe it's because of ATI.

When I searched for the exact same problem few years ago, this was the solution. Yet, I have KoTOR and KoTOR-II on this system and without this solution I'm having this problem too.

Since I don't have an ATI card, I can't be %100 sure but that first option in Image Section may be your solution as well. Because this common problem is absolutely about texture compression. Please take a look if you can solve your problem via changing "At least 1 texture must fit under worst-case assumptions" option.