Results 1 to 9 of 9

Thread: Phpmyadmin Fatal error: Allowed memory size of 16777216 bytes exhausted

  1. #1
    Join Date
    Mar 2008
    Beans
    42

    Phpmyadmin Fatal error: Allowed memory size of 16777216 bytes exhausted

    I'm getting this error when trying to import a database file in phpmyadmin
    Fatal error: Allowed memory size of 16777216 bytes exhausted (tried to allocate 13937832 bytes) in /usr/share/phpmyadmin/libraries/unzip.lib.php on line 325.

    I edited the php.ini file and increased the memory to 32M but still the same error message.

    How to I solve this? I also dont understand how 13mb can exhaust 16mb of memory?

  2. #2
    Join Date
    Sep 2005
    Location
    Watertown, SD
    Beans
    214
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Phpmyadmin Fatal error: Allowed memory size of 16777216 bytes exhausted

    Did you restart apache after changing your php.ini?

  3. #3
    Join Date
    Mar 2008
    Beans
    42

    Re: Phpmyadmin Fatal error: Allowed memory size of 16777216 bytes exhausted

    i rebooted the server

    whats the command to restart apache anyway?

  4. #4
    Join Date
    Sep 2005
    Location
    Watertown, SD
    Beans
    214
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Phpmyadmin Fatal error: Allowed memory size of 16777216 bytes exhausted

    /etc/init.d/apache2 restart

    hrm...

  5. #5
    Join Date
    Mar 2008
    Beans
    42

    Re: Phpmyadmin Fatal error: Allowed memory size of 16777216 bytes exhausted

    still did'nt solve the issue anyway

  6. #6
    Join Date
    Sep 2005
    Location
    Watertown, SD
    Beans
    214
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: Phpmyadmin Fatal error: Allowed memory size of 16777216 bytes exhausted

    Sorry, if you've edited the php.ini and changed the value that was already there from 16M to 32M and restarted, I'm not sure what else to tell ya...

    Just to be sure the php.ini file that you edited was in:

    /etc/php5/apache2/php.ini?

    And you did change the value instead of adding a second variable right?

    memory_limit = 32M

    Just double checking, this is the only place I know of to allow php to use more memory and is exactly the setting I'm using for my server (with phpmyadmin installed).

    After dark the real experts will come out

  7. #7
    Join Date
    Jan 2006
    Beans
    10

    Re: Phpmyadmin Fatal error: Allowed memory size of 16777216 bytes exhausted

    Quote Originally Posted by TwiceOver View Post
    Sorry, if you've edited the php.ini and changed the value that was already there from 16M to 32M and restarted, I'm not sure what else to tell ya...

    Just to be sure the php.ini file that you edited was in:

    /etc/php5/apache2/php.ini?

    And you did change the value instead of adding a second variable right?

    memory_limit = 32M

    Just double checking, this is the only place I know of to allow php to use more memory and is exactly the setting I'm using for my server (with phpmyadmin installed).

    After dark the real experts will come out
    It can also be set inside any apache config file. Specifically, I would check /etc/apache2/sites-enabled/phpmyadmin.conf or /etc/apache2/conf.d/phpmyadmin.conf or any .htaccess in phpmyadmin directories to see if its being overriden. You can also check by creating a file in /var/www with <?php phpinfo(); ?> and seeing what the memory limit its reading from php.ini, that should help tell if phpmyadmin's setting is getting overriden.

  8. #8
    Join Date
    Oct 2008
    Beans
    2

    Re: Phpmyadmin Fatal error: Allowed memory size of 16777216 bytes exhausted

    Note that there may also be a .htaccess file in the phpmyadmin filder that restricts the memory_limit to a different value than the server default values.

  9. #9
    Join Date
    Mar 2006
    Location
    Williams Lake
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: Phpmyadmin Fatal error: Allowed memory size of 16777216 bytes exhausted

    Most of the answers given in this three year old thread, don't apply any more. Thread Closed.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •