bipa, thanks for the feedback. You've confirmed my understanding of Airport Classic - i.e. to use WEP you have to use an older version of the firmware.

Would it be possible to zip up your 9.52 firmware and post/attach it here? It may well be useful to others requiring WPA and network manager.

I'd be willing to add a confirmation about this in the FAQ but the wiki does not seem to allow such edits (page is not editable for me).
Have you got a launchpad account? It's a bit funny when you first log in to the wiki pages; you seem to have to do it twice.