Results 1 to 10 of 10

Thread: Video error when watching a RTE player TV program

  1. #1
    Join Date
    Feb 2008
    Location
    Munster, Ireland
    Beans
    2,297
    Distro
    Xubuntu

    Question Video error when watching a RTE player TV program

    Hi.

    A relative was going to watch this TV program in Firefox (sorry but I am not sure if someone else can watch it outside Ireland) http://www.rte.ie/player/ie/show/10067440/. He got the error "(UNCAUGHT) Error #2203" as seen in the attached image.

    He can watch YouTube videos without any problems. I tried another browser (Chromium) but had the same issue.

    I disabled the adblock addons on both browsers and the video played the adverts but when it eventually got to the main TV program - the same error appeared.

    He is using Ubuntu 12.04 with all updates applied. I also ran bleachbit.

    Please help. Thanks.
    Attached Images Attached Images
    Last edited by Rytron; July 19th, 2013 at 09:45 AM.
    1st Distro used (live CD): Knoppix in early 2007 ¦ 1st Distro Installed: Ubuntu 7.10 in Feb 2008
    GNU/Linux User #470660 – Ubuntu User #28226
    Isaac Asimov: "I do not fear computers. I fear the lack of them."

  2. #2
    Join Date
    Oct 2012
    Beans
    1

    Re: Video error when watching a RTE player TV program

    Hi,
    Your getting this error because the video is encrypted / DRM'd. To play this video the flash player downloads the required library into ~/adobe/Flash_Player/NativeCache/.... The problem is this downloaded library requires libhal which is not installed by default in a new install anymore. The following steps will fix the issue (they may not all be necessary but it does work)

    Close all browser windows

    1) remove the adobe cache - rm ~/.adobe -rf
    2) install hal & hal-info - sudo apt-get install hal hal-info

    3) reinstall adobe player - sudo apt-get install flashplugin-installer --reinstall

    Open your browser and you should be good to go !!

    Ruairi

  3. #3
    Join Date
    Feb 2008
    Location
    Munster, Ireland
    Beans
    2,297
    Distro
    Xubuntu

    Re: Video error when watching a RTE player TV program

    Quote Originally Posted by TokyoCrusaders92 View Post
    Hi,
    Your getting this error because the video is encrypted / DRM'd. To play this video the flash player downloads the required library into ~/adobe/Flash_Player/NativeCache/.... The problem is this downloaded library requires libhal which is not installed by default in a new install anymore. The following steps will fix the issue (they may not all be necessary but it does work)

    Close all browser windows

    1) remove the adobe cache - rm ~/.adobe -rf
    2) install hal & hal-info - sudo apt-get install hal hal-info

    3) reinstall adobe player - sudo apt-get install flashplugin-installer --reinstall

    Open your browser and you should be good to go !!

    Ruairi
    Cheers Ruairi. I will give it a go and tell you how it goes.
    ...
    1st Distro used (live CD): Knoppix in early 2007 ¦ 1st Distro Installed: Ubuntu 7.10 in Feb 2008
    GNU/Linux User #470660 – Ubuntu User #28226
    Isaac Asimov: "I do not fear computers. I fear the lack of them."

  4. #4
    Join Date
    Apr 2006
    Beans
    1

    Smile Re: Video error when watching a RTE player TV program

    I had the same problem and the the suggested solution worked

    Thanks folks

  5. #5
    Join Date
    Feb 2008
    Location
    Munster, Ireland
    Beans
    2,297
    Distro
    Xubuntu

    Re: Video error when watching a RTE player TV program

    Quote Originally Posted by limcearna View Post
    I had the same problem and the the suggested solution worked

    Thanks folks
    Ditto. Just tried the solution last night, worked a charm. Thanks again TokyoCrusaders92 (Ruairi).
    1st Distro used (live CD): Knoppix in early 2007 ¦ 1st Distro Installed: Ubuntu 7.10 in Feb 2008
    GNU/Linux User #470660 – Ubuntu User #28226
    Isaac Asimov: "I do not fear computers. I fear the lack of them."

  6. #6
    Join Date
    Oct 2010
    Beans
    6

    Re: Video error when watching a RTE player TV program

    Thanks, the fix worked perfectly.

  7. #7
    Join Date
    Dec 2005
    Beans
    1

    Re: Video error when watching a RTE player TV program

    Quote Originally Posted by TokyoCrusaders92 View Post
    Hi,
    Your getting this error because the video is encrypted / DRM'd. To play this video the flash player downloads the required library into ~/adobe/Flash_Player/NativeCache/.... The problem is this downloaded library requires libhal which is not installed by default in a new install anymore. The following steps will fix the issue (they may not all be necessary but it does work)

    Close all browser windows

    1) remove the adobe cache - rm ~/.adobe -rf
    2) install hal & hal-info - sudo apt-get install hal hal-info

    3) reinstall adobe player - sudo apt-get install flashplugin-installer --reinstall

    Open your browser and you should be good to go !!

    Ruairi
    I have Ubuntu 12.10 with Gnome 3 and this fix worked perfectly me. Thanks! Now I won't need to miss a single episode of Home and Away!

  8. #8
    Join Date
    Nov 2012
    Beans
    2

    Re: Video error when watching a RTE player TV program

    So the same fix can be applied to any other browser installed in Ubuntu?. Hope so.

  9. #9
    Join Date
    Feb 2008
    Location
    Munster, Ireland
    Beans
    2,297
    Distro
    Xubuntu

    Exclamation Re: Video error when watching a RTE player TV program

    I've just checked my laptop (Xubuntu 12.04) and got the same error. The above fix worked a charm.

    However my main PC (Linux Mint 13) will no longer play any RTE Player TV programs since about 3 days ago. I get no error message, just this [image attached]. I tried the above fix and even rebooted but no joy.

    Update: This alt site works fine, http://www.rte.ie/playerxl/
    Attached Images Attached Images
    Last edited by Rytron; December 23rd, 2012 at 09:04 PM.
    1st Distro used (live CD): Knoppix in early 2007 ¦ 1st Distro Installed: Ubuntu 7.10 in Feb 2008
    GNU/Linux User #470660 – Ubuntu User #28226
    Isaac Asimov: "I do not fear computers. I fear the lack of them."

  10. #10
    Join Date
    Apr 2013
    Beans
    1

    Thumbs up Re: Video error when watching a RTE player TV program

    Quote Originally Posted by TokyoCrusaders92 View Post

    Close all browser windows

    1) remove the adobe cache - rm ~/.adobe -rf
    2) install hal & hal-info - sudo apt-get install hal hal-info

    3) reinstall adobe player - sudo apt-get install flashplugin-installer --reinstall

    Open your browser and you should be good to go !!

    Ruairi

    Thanks Ruairi, I've been meaning to try and fix this for a while and your instructions worked perfectly. (Using Linux Mint Maya - KDE)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •