Results 1 to 10 of 10

Thread: Xfce Power Manager

  1. #1
    Join Date
    Aug 2012
    Beans
    3

    Xfce Power Manager

    Hey,

    I am using an Ubuntu installation with Xfce as desktop environment on my Thinkpad E520. After installing updates (including a reboot) my power manager stopped working and I also get crash reports about the network manager on every start. I tried reinstalling (sudo apt-get remove, then install) xfce4-power-manager, but it didn't help. Here are some screenshots:

    https://dl.dropbox.com/u/12769915/power1.png
    https://dl.dropbox.com/u/12769915/power2.png
    (The text says "Can't establish connection to the power manager for Xfce")

    Any ideas how to fix this problem?

    muCkk

  2. #2
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Xfce Power Manager

    Hello themuCkk and welcome to the forums.

    Is xfce4-power-manager running? You can check by typing in the following in a terminal window:
    Code:
    ps -ef | grep xfce4-power
    There also might be some useful information in the ~/.xsession-errors log file.

  3. #3
    Join Date
    Aug 2012
    Beans
    3

    Re: Xfce Power Manager

    Hello,

    xfce4-power is running. The only related message in the log was this:
    (xfce4-power-manager-settings:3227): xfce4-power-manager-settings-CRITICAL **: Unable to get configuration information from xfce power manager: Did not receive a reply. Possible causes include: the remote application did not send a reply, the message bus security policy blocked the reply, the reply timeout expired, or the network connection was broken.
    Thanks for your fast reply .

  4. #4
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Xfce Power Manager

    Try clearing out your sessions cache. Logout form Xfce, Ctrl+Alt+F1 to go to first tty, login to tty (text-based), clear the cache with:
    Code:
    rm -rf ~/.cache/sessions
    ...then go back to the GUI (Ctrl+Alt+F7) and log back in.

  5. #5
    Join Date
    Aug 2012
    Beans
    3

    Re: Xfce Power Manager

    That solved it, thanks!

  6. #6
    Join Date
    Nov 2012
    Beans
    1

    Re: Xfce Power Manager

    Quote Originally Posted by Toz View Post
    Try clearing out your sessions cache. Logout form Xfce, Ctrl+Alt+F1 to go to first tty, login to tty (text-based), clear the cache with:
    Code:
    rm -rf ~/.cache/sessions
    ...then go back to the GUI (Ctrl+Alt+F7) and log back in.
    That helped me also. Thanks, Toz!

  7. #7
    Join Date
    Aug 2013
    Beans
    1

    Cool Re: Xfce Power Manager

    Quote Originally Posted by Mavashi View Post
    That helped me also. Thanks, Toz!
    If the problem consists in thunar, right after login, waiting long time before opening home and doing it after error message (unspecified resource/directory not available), it seems solved by a small change in : /etc/nsswitch.conf.

    The original line: [hosts: files dns]
    when changed to: [hosts: files wins dns]

    seems to solve the problem without further interventions.
    Even the "Network" link in thunar works out of the box.

  8. #8
    Join Date
    Oct 2013
    Beans
    0

    Re: Xfce Power Manager

    Quote Originally Posted by Toz View Post
    Try clearing out your sessions cache. Logout form Xfce, Ctrl+Alt+F1 to go to first tty, login to tty (text-based), clear the cache with:
    Code:
    rm -rf ~/.cache/sessions
    ...then go back to the GUI (Ctrl+Alt+F7) and log back in.
    Thanks Toz! Helped me out as well! Cheers mate!

  9. #9
    Join Date
    Nov 2013
    Location
    europe
    Beans
    29

    Re: Xfce Power Manager

    Quote Originally Posted by Toz View Post
    Try clearing out your sessions cache. Logout form Xfce, Ctrl+Alt+F1 to go to first tty, login to tty (text-based), clear the cache with:
    Code:
    rm -rf ~/.cache/sessions
    ...then go back to the GUI (Ctrl+Alt+F7) and log back in.
    worked for me

  10. #10
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: Xfce Power Manager

    This fix, although still valid, was necessary for earlier versions of Xfce. The later versions of Xfce (4.10+) including the version in 14.04 has added the ability to clear the sessions cache without the need to go to a text console. Look for it in Settings Manager >> Session and Startup >> Session tab >> "Clear saved sessions". It is much easier now to clear the saved sessions cache.

    Closing this thread.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •