I'm trying to install libboost onto 12.04 using the Ubuntu software centre, but I get the error:

libboost-all-dev:i386: libboost1.46-dev:i386: Depends: libc6 (>= 2.11) but 2.15-0ubuntu10.3 is to be installed
Depends: libgcc1 (>= 1:4.1.1) but 1:4.6.3-1ubuntu5 is to be installed
Depends: libstdc++6 (>= 4.6) but 4.6.3-1ubuntu5 is to be installed

What am I doing wrong, and how do I fix it?

Thanks.