Results 1 to 10 of 10

Thread: Telstra 4G Mobile Broadband Setup

Threaded View

  1. #1
    Join Date
    May 2010
    Location
    Australia
    Beans
    Hidden!
    Distro
    Ubuntu

    Telstra 4G Mobile Broadband Setup

    I recently purchased a Telstra 4G USB device and anticipated I'd need to jump through a few hoops to get this to work on Kubuntu (12.10).
    In fact getting this up and running proved quite simple...

    After connecting the unit to a USB port I ran lsusb, with the following output;

    Code:
    Bus 001 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 002 Device 002: ID 8087:0024 Intel Corp. Integrated Rate Matching Hub
    Bus 003 Device 003: ID 19d2:0257 ZTE WCDMA Technologies MSM 
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 003 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 004 Device 001: ID 1d6b:0003 Linux Foundation 3.0 root hub
    Bus 001 Device 003: ID 064e:c21c Suyin Corp.
    Using this information I went to /lib/udev/rules.d/40-usb_modeswitch.rules and added the following entry;
    Code:
    # ZTE MF821 4G LTE
    ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="0257", RUN+="usb_modeswitch '%b/%k'"
    As you can see all I did was copy the closest entry in description, which was
    Code:
    # ZTE MF820 4G LTE 
    ATTRS{idVendor}=="19d2", ATTRS{idProduct}=="0166", RUN+="usb_modeswitch '%b/%k'"
    and substitute the correct values from the earlier usb scan.

    I then created a file called 19d2:0257 in /etc/usb_modeswitch.d/ and put in the following,
    Code:
    # Telstra ZTE LTE 4g modem
    #
    DefaultVendor=  0x19d2
    DefaultProduct= 0x0257
    
    TargetVendor=  0x19d2
    TargetProduct= 0x0257
    
    MessageContent="55534243123456782400000080000685000000240000000000000000000000"
    
    CheckSuccess=20
    Finally, to have Network Manager automatically recognise the device I added the following line to /etc/rc.local;
    Code:
    modprobe usbserial vendor=0x19d2 product=0x0257
    Now the device is recognised as a Mobile Broadband connection whenever it is plugged including after a reboot.

    cheers
    Last edited by bra|10n; October 24th, 2012 at 06:44 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •