Results 1 to 5 of 5

Thread: system76-driver 3.2.1 requires python 2.7?

  1. #1
    Join Date
    Sep 2010
    Beans
    898

    system76-driver 3.2.1 requires python 2.7?

    This morning the package "system76-driver" showed up as upgradable in synaptic, but when I try to upgrade it (version 3.2.0 to 3.2.1), I get a dependency error:

    system76-driver:
    Depends: python (>=2.7) but 2.6.5-0ubuntu1 is to be installed
    I'm running Ubuntu 10.04.4, which is still supported, but has python 2.6.5.

    Does system76-driver really require python >= 2.7?

  2. #2
    Join Date
    Oct 2007
    Location
    Aurora, CO
    Beans
    2,563
    Distro
    Ubuntu

    Re: system76-driver 3.2.1 requires python 2.7?

    Quote Originally Posted by Dave_L View Post
    This morning the package "system76-driver" showed up as upgradable in synaptic, but when I try to upgrade it (version 3.2.0 to 3.2.1), I get a dependency error:



    I'm running Ubuntu 10.04.4, which is still supported, but has python 2.6.5.

    Does system76-driver really require python >= 2.7?
    Yes, the requirements are as low as we can keep them, however you will need at least python 2.7 in order for everything to run properly.
    Ian Santopietro - System76 Technical Support.
    Open a Support Ticket!
    Ask a Sales Question!

  3. #3
    Join Date
    Sep 2010
    Beans
    898

    Re: system76-driver 3.2.1 requires python 2.7?

    Thanks for the response.

    Does that mean that System76 no longer supports Ubuntu 10.04?

  4. #4
    Join Date
    Oct 2007
    Location
    Aurora, CO
    Beans
    2,563
    Distro
    Ubuntu

    Re: system76-driver 3.2.1 requires python 2.7?

    Quote Originally Posted by Dave_L View Post
    Thanks for the response.

    Does that mean that System76 no longer supports Ubuntu 10.04?
    On Desktop/Laptop machines, we officially support the latest version of Ubuntu. We can usually also support the latest LTS. But for anything older than that, our ability to provide support is limited.

    What model do you have? You shouldn't need anything newer than 3.0.0 for 10.04, since we only really make changes for the current Ubuntu version.
    Last edited by isantop; October 19th, 2012 at 04:37 PM.
    Ian Santopietro - System76 Technical Support.
    Open a Support Ticket!
    Ask a Sales Question!

  5. #5
    Join Date
    Sep 2010
    Beans
    898

    Re: system76-driver 3.2.1 requires python 2.7?

    Quote Originally Posted by isantop View Post
    On Desktop/Laptop machines, we officially support the latest version of Ubuntu. We can usually also support the latest LTS. But for anything older than that, our ability to provide support is limited.

    What model do you have? You shouldn't need anything newer than 3.0.0 for 10.04, since we only really make changes for the current Ubuntu version.
    I have a star3.

    Thanks for the advice. I'll stick with system76-driver 3.2.0. I've disabled the system76 repository so I won't get nagged about upgrades for the driver.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •