Page 1 of 2 12 LastLast
Results 1 to 10 of 13

Thread: Improve sound quality for a Windows guest

  1. #1
    Join Date
    Jan 2012
    Beans
    753

    Improve sound quality for a Windows guest

    I'm trying to run Windows 7 in VirtualBox (host is Kubuntu 12.04), but the sound quality is atrocious. Even simple beeps sounds broken up and crackly. Is there any way I can fix this? I've tried adjusting settings on the Windows guest, but nothing is working...

  2. #2
    Join Date
    Feb 2008
    Location
    Pelican Bay Correctional
    Beans
    Hidden!

    Re: Improve sound quality for a Windows guest

    Guest Extensions/Pack installed?

    What Vbox version?
    What's a landing but a take off in reverse?

  3. #3
    Join Date
    Jan 2012
    Beans
    753

    Re: Improve sound quality for a Windows guest

    Oh yes, I forgot. My VirtualBox version is "4.1.12_Ubuntu". And yes, I have the Guest Extensions Pack installed. Here are the settings for VirtualBox, btw.

  4. #4
    Join Date
    Jan 2012
    Beans
    753

    Re: Improve sound quality for a Windows guest

    bump

  5. #5
    Join Date
    Feb 2010
    Beans
    18

    Re: Improve sound quality for a Windows guest

    What are your PC's specs?

  6. #6
    Join Date
    Jan 2012
    Beans
    753

    Re: Improve sound quality for a Windows guest

    Quote Originally Posted by kow777 View Post
    What are your PC's specs?
    It's a laptop, but it's a gaming laptop, so it's pretty powerful. It's a MainGear ex-L 15 SuperStock.

    CPU: 64-bit Intel Core i7-2760QM @ 2.4 GHz (3.5 GHz Turbo)
    GPU: Nvidia GeForce GTX 675m
    Memory: 2x Corsair Vengeance 8 GB DDR3 @ 1600MHz

    So I doubt it's that my computer is unable to run Windows virtualized. In fact, I've been able to get away with running Kubuntu 12.04, Windows 7, PC-BSD, and more than 5 clones of Tails (a debian-based hardened OS) at once. Then I tried opening Fedora 16 and my computer crashed instantly (I had no swap enabled at the time so maybe that's why).

    I also have Intel's VT-x (?) virtualization enabled in the BIOS.

  7. #7
    Join Date
    Feb 2010
    Beans
    18

    Re: Improve sound quality for a Windows guest

    Quote Originally Posted by Stonecold1995 View Post
    It's a laptop, but it's a gaming laptop, so it's pretty powerful. It's a MainGear ex-L 15 SuperStock.

    CPU: 64-bit Intel Core i7-2760QM @ 2.4 GHz (3.5 GHz Turbo)
    GPU: Nvidia GeForce GTX 675m
    Memory: 2x Corsair Vengeance 8 GB DDR3 @ 1600MHz

    So I doubt it's that my computer is unable to run Windows virtualized. In fact, I've been able to get away with running Kubuntu 12.04, Windows 7, PC-BSD, and more than 5 clones of Tails (a debian-based hardened OS) at once. Then I tried opening Fedora 16 and my computer crashed instantly (I had no swap enabled at the time so maybe that's why).

    I also have Intel's VT-x (?) virtualization enabled in the BIOS.
    Do you have this issue with any other OS? Maybe it is just Windows being weird, as it tends to be sometimes.
    I would try to decrease the number of "cores" the VM has. Try setting it to four.

  8. #8
    Join Date
    Jul 2007
    Location
    Atlanta, GA
    Beans
    89
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: Improve sound quality for a Windows guest

    Do you have this issue in other software? like viewing video's in a browser, playing games, etc. (in the host OS (ubuntu, etc) instead of the guest (win 7)
    It could be audio drivers on the host (the laptop)

    Also, try changing the audio settings on the guest OS settings page, before starting the virtualbox session go to settings -> audio and change it, mine is set to PulseAudio, there are also settings for which audio controller to use.
    Last edited by Insomn1a; October 14th, 2012 at 07:59 PM.
    An expert is a man who has made all the mistakes which can be made in a very narrow field.
    -Niels Bohr

  9. #9
    Join Date
    Feb 2010
    Beans
    18

    Re: Improve sound quality for a Windows guest

    Quote Originally Posted by Insomn1a View Post
    Also, try changing the audio settings on the guest OS settings page, before starting the virtualbox session go to settings -> audio and change it, mine is set to PulseAudio, there are also settings for which audio controller to use.
    Derp... Didn't think about that...

  10. #10
    Join Date
    Jan 2012
    Beans
    753

    Re: Improve sound quality for a Windows guest

    Quote Originally Posted by Insomn1a View Post
    Do you have this issue in other software? like viewing video's in a browser, playing games, etc. (in the host OS (ubuntu, etc) instead of the guest (win 7)
    It could be audio drivers on the host (the laptop)

    Also, try changing the audio settings on the guest OS settings page, before starting the virtualbox session go to settings -> audio and change it, mine is set to PulseAudio, there are also settings for which audio controller to use.
    I haven't tried videos in a browser, although videos work fine in WMP (the audio doesn't). The games I've tried worked, and I've tried Touhou Project 7.5, BlankBlood, CrackleCradle, and Demonophobia, and they've all played at normal speeds, but with messed up audio (with the exception of Demonophobia, which has no audio at all). The Windows Experience Index is 6.7 (processor), 7.9 (memory), 2.9 (graphics), 2.2 (gaming graphics), 6.7 (hard disk), and 2.2 (total).

    I tried changing the audio settings, and only "Intel HD Audio" worked. The others caused Windows to tell me there's an error with the audio device.
    Last edited by Stonecold1995; October 14th, 2012 at 09:51 PM.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •