Tried again with Wireless adapter turned off at laptop. No luck. I have been disconnecting the wireless when trying to connect beforehand. From now on I'll turn off properly but it seems to have made no difference.