Thanks, using the old releases could be an option.

Or maybe 12.04 will mature sufficiently.

Or maybe one of the other distros ....