Results 1 to 5 of 5

Thread: 12.04 Screen Blanking

  1. #1
    Join Date
    May 2008
    Location
    /home
    Beans
    506
    Distro
    Ubuntu 12.04 Precise Pangolin

    Question 12.04 Screen Blanking

    I have set Power to Don't suspend & Brightness and lock => Turn screen off when inactive for: Never. But display still blanks after 10 mins. This seems to be after a recent update. I've also rummaged through dconf editor, I am using GNOME III.

    Code:
    xset q | grep -A4 DPMS
    Returns:

    Code:
    DPMS (Energy Star):
      Standby: 600    Suspend: 600    Off: 600
      DPMS is Enabled
      Monitor is On
    However trying various switches:

    Code:
    xset -dpms
    xset s off
    xset s noblamk
    fails to adjust the 600 second time out. Is my syntax wrong? I've found this bug report, but it is for 11.10 & I'm not sure what package to report against if any? Listening to music via monitor speakers gets cut out every time monitor blanks. I do not always listen through stereo, as we all live on top of each other here (so monitor speakers carry less bass.)

    Any help much appreciated...
    Last edited by fleamour; October 8th, 2012 at 06:34 PM.
    Vintage IBM ThinkPad T21 laptop 1GHz PIII [T22 heatsink] ~ Silicon Heaven [RIP]
    AMD64 Lenovo ThinkPad Edge325 ~ openSUSE 12.3 KDE [Tumbleweed repos]
    PC C2D Tower ~ 32-bit 7 Ultimate/64-bit Ubuntu Precise 12.04 GNOME fallback [LTS]

  2. #2
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,845
    Distro
    Ubuntu Development Release

    Re: 12.04 Screen Blanking

    Here's the workaround I use (when watching long videos & movies):

    Code:
    xset s off && xset dpms force on && xset -dpms
    To check the status (or use your command, above):

    Code:
    xset q | grep -A1 -i dpms
    Resets to normal on boot/restart...
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  3. #3
    Join Date
    May 2008
    Location
    /home
    Beans
    506
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 12.04 Screen Blanking

    Hopefully this bug will be fixed sometime. Shame fix not persistent between reboots, but thanks for the prompt response. I do suspend in preference to reboot so goes some way to resolving, cheerz!

    Vintage IBM ThinkPad T21 laptop 1GHz PIII [T22 heatsink] ~ Silicon Heaven [RIP]
    AMD64 Lenovo ThinkPad Edge325 ~ openSUSE 12.3 KDE [Tumbleweed repos]
    PC C2D Tower ~ 32-bit 7 Ultimate/64-bit Ubuntu Precise 12.04 GNOME fallback [LTS]

  4. #4
    Join Date
    Aug 2010
    Location
    Arizona USA
    Beans
    2,845
    Distro
    Ubuntu Development Release

    Re: 12.04 Screen Blanking

    Quote Originally Posted by fleamour View Post
    Hopefully this bug will be fixed sometime. Shame fix not persistent between reboots [...]
    Well, as you properly stated, it's a bug.

    I deal with dev releases, which change daily, sometimes hourly.

    I've seen this bug fixed, and broken again, a couple of times in 12.10.

    I just checked... and the workaround must have "stuck", because the values are still set to "0". It wasn't this way in the past.

    I haven't used this command in a few days, and it has apparently survived several reboots, soooo maybe it'll "stick" for you, too, although we're running different releases.

    Anyway, good luck. Hope it works out for you...
    Intel ® P4 Extreme Edition 3.4 (Gallatin) || DFI ® LanParty PRO875B rev B1
    Crucial ® Ballistix Tracer PC4000 1GB || Mountain Mods U2-UFO Opti-1203
    XFX 7600GT 560M AGP (PV-T73A-UDF3) || Corsair HX520W Modular PSU

  5. #5
    Join Date
    Mar 2009
    Location
    The Freight Yard
    Beans
    174
    Distro
    Xubuntu 14.04 Trusty Tahr

    Re: 12.04 Screen Blanking

    I've been running this little script when I start Xfce & it seems to work for me.

    I named it nodpms.

    Code:
    #!/bin/bash
    xset dpms 0 0 0
    xset -dpms
    xset s noblank
    xset s noexpose
    xset q
    Below is what I get after opening a terminal & entering ./nodpms.


    Code:
    Home Page:~$ ./nodpms
    Keyboard Control:
      auto repeat:  on    key click percent:  0    LED mask:  00000000
      XKB indicators:
        00: Caps Lock:   off    01: Num Lock:    off    02: Scroll Lock: off
        03: Compose:     off    04: Kana:        off    05: Sleep:       off
        06: Suspend:     off    07: Mute:        off    08: Misc:        off
        09: Mail:        off    10: Charging:    off    11: Shift Lock:  off
        12: Group 2:     off    13: Mouse Keys:  off
      auto repeat delay:  500    repeat rate:  33
      auto repeating keys:  00ffffffdffffbbf
                            fadfffefffedffff
                            9fffffffffffffff
                            fff7ffffffffffff
      bell percent:  50    bell pitch:  400    bell duration:  100
    Pointer Control:
      acceleration:  30/10    threshold:  10
    Screen Saver:
      prefer blanking:  no    allow exposures:  no
      timeout:  0    cycle:  0
    Colors:
      default colormap:  0x20    BlackPixel:  0    WhitePixel:  16777215
    Font Path:
      /usr/share/fonts/X11/misc,/usr/share/fonts/X11/100dpi/:unscaled,/usr/share/fonts/X11/Type1,/usr/share/fonts/X11/100dpi,built-ins
    DPMS (Energy Star):
      Standby: 0    Suspend: 0    Off: 0
      DPMS is Disabled
    Home Page:~$
    The first line turns Standby, Suspend & Off to 0.
    Second turns off DPMS.

    Hope this helps.
    Last edited by SantaFe; October 9th, 2012 at 03:01 PM.
    I'm a man, I can re-install, if I have to, I guess!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •