Results 1 to 3 of 3

Thread: Neverwinter Nights sound issues

  1. #1
    Join Date
    Oct 2012

    Neverwinter Nights sound issues

    I am having a great deal of difficulty getting sounds active in NWN (platinum CD install)...
    I've altered the nwn run script in every way I've found on this, and many other forums, all to no avail.
    I Did get it working for about 12 hours with the addition of the

    export SDL_AUDIODRIVERS=alsa

    command line, but did a system restart and it has gone kaput.
    Nothing I have tried since has had any effect whatsoever besides turning my hair grey.

    Currently, my nwn run script reads as -


    # This script runs Neverwinter Nights from the current directory

    export SDL_VIDEO_X11_DGAMOUSE=0
    #export SDL_AUDIODRIVERS=alsa

    # If you do not wish to use the SDL library included in the package, remove
    # ./lib from LD_LIBRARY_PATH
    export LD_LIBRARY_PATH=:./miles:$LD_LIBRARY_PATH

    ./nwmain $@

    and nothing sound-wise...
    (sound aside, game runs flawlessly, no high res screen flutter/flicker, no mouse lag, movies work (sans sound)

    I've tried the ravage installer, leech's guide, and a variety of other potential fixes I've found all to no avail.

    any help would be appreciated.
    Last edited by stackmanpf77; October 9th, 2012 at 12:18 PM.

  2. #2
    Join Date
    Sep 2011

    Re: Neverwinter Nights sound issues

    I'm having the same problems.
    What's odd though, is I've gotten it working on Gentoo, and Ubuntu before.
    My only thoughts are, maybe Ubuntu Studio (and other odd derivatives) has something missing that the vanilla install has, or that the 12.04.1 update changed something.
    I've got ia32 and multiarch so I'm just not too sure. Maybe I missed some package on the install disk.

    (edit: I'm not sure why this is labeled as solved. =P crazy mods.)

  3. #3
    Join Date
    Oct 2012

    Re: Neverwinter Nights sound issues

    haha, nope it was me not the mods that marked it as solved

    my sound problems merely came from my sound preferences magically resetting themselves to defaults when i did a reboot :/

    once I'd switched them back to what they shoulda been, it fired up sweet-as...



Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts