Results 1 to 8 of 8

Thread: Backlit Keyboard automatically on

  1. #1
    Join Date
    Nov 2011
    Beans
    7

    Smile Backlit Keyboard automatically on [SOLVED]

    I have a macbook pro and am running Ubuntu 12.04. Every time I turn on my computer the backlit keyboard turns to the maximum automatically and I have to lower it to zero. This is not a big deal, but it is annoying... Anyone know how to configure ubuntu to not turn on the backlit keyboard when the computer turns on?
    Last edited by alexferreirag; October 7th, 2012 at 05:49 AM. Reason: issue was solved

  2. #2
    Join Date
    Oct 2011
    Beans
    11

    Re: Backlit Keyboard automatically on

    It's not the best solution, but add
    Code:
    echo '1' > /sys/devices/platform/applesmc.768/leds/smc::kbd_backlight/brightness
    to /etc/rc.local
    This will lower the brightness to the lowest possible value at boot, from there you can leave it (its hardly noticable) or just hit the brightness down key once. For some reason, 0 doesn't work (at least for me)
    Last edited by Sileem; October 6th, 2012 at 11:19 PM. Reason: Forgot to add where to add the line.

  3. #3
    Join Date
    Nov 2011
    Beans
    7

    Re: Backlit Keyboard automatically on

    Quote Originally Posted by Sileem View Post
    It's not the best solution, but add
    Code:
    echo '1' > /sys/devices/platform/applesmc.768/leds/smc::kbd_backlight/brightness
    This will lower the brightness to the lowest possible value at boot, from there you can leave it (its hardly noticable) or just hit the brightness down key once. For some reason, 0 doesn't work (at least for me)
    I am not allowed to do that command, not even with sudo, so am I supposed to replace the '0' with a '1', a 'echo '1'', or to add a '1' or 'echo '1'' (I am editing the file through nano)?

  4. #4
    Join Date
    Nov 2010
    Location
    NM
    Beans
    1,121
    Distro
    Lubuntu Development Release

    Re: Backlit Keyboard automatically on

    Quote Originally Posted by alexferreirag View Post
    I am not allowed to do that command, not even with sudo, so am I supposed to replace the '0' with a '1', a 'echo '1'', or to add a '1' or 'echo '1'' (I am editing the file through nano)?
    Try
    Code:
    sudo su
    Before the echo command
    Boot Info Script
    Ubuntu User number is # 32763
    Linux User number is # 527179

  5. #5
    Join Date
    Oct 2011
    Beans
    11

    Re: Backlit Keyboard automatically on

    Quote Originally Posted by alexferreirag View Post
    I am not allowed to do that command, not even with sudo, so am I supposed to replace the '0' with a '1', a 'echo '1'', or to add a '1' or 'echo '1'' (I am editing the file through nano)?
    Whoops, sorry, I meant to say add that line to the file /etc/rc.local

  6. #6
    Join Date
    Oct 2012
    Location
    USA
    Beans
    99
    Distro
    Ubuntu 13.04 Raring Ringtail

    Smile Re: Backlit Keyboard automatically on

    Solution seems to work for me. Thanks guys!

  7. #7
    Join Date
    Nov 2011
    Beans
    7

    Re: Backlit Keyboard automatically on

    Quote Originally Posted by Sileem View Post
    Whoops, sorry, I meant to say add that line to the file /etc/rc.local
    Yep, now it works!

  8. #8
    Join Date
    Oct 2011
    Beans
    11

    Re: Backlit Keyboard automatically on

    However, there are some problems with this method, the backlight will turn on when you log out, and randomly when it wakes up.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •