Results 1 to 5 of 5

Thread: Colour-blind: colours in Command Line output

  1. #1
    Join Date
    Aug 2012
    Location
    Netherlands
    Beans
    72
    Distro
    Ubuntu 14.04 Trusty Tahr

    Colour-blind: colours in Command Line output

    Hi,
    I'm asking this question not for myself but for a friend who is colour-blind (completely; he only sees black white and grey)

    Is there a way to get rid of the colours in Command Line? I mean things like maps are blue (right?) and that sort of stuff. Can it be reset in such a way that there are no colours?

    Thanks

  2. #2
    Join Date
    Apr 2005
    Location
    Finland/UK
    Beans
    Hidden!
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Colour-blind: colours in Command Line output

    sure.

    The easiest option might be just switching the settings in the terminal application you are using, for example Gnome-terminal has pretty detailed color configuration options in the terminal profile.

    ..and the alternative way, which would affect all terminals and TTY's, is to edit your ~/.bashrc file, it has an option to enbable/disable colors in Bash. (sadly I'm not at my Linux machine at the moment so I can't tell you the exact line, but it should be pretty clear if you read the file)
    Last edited by mcduck; October 5th, 2012 at 12:44 PM.

  3. #3
    Join Date
    Aug 2012
    Location
    Netherlands
    Beans
    72
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Colour-blind: colours in Command Line output

    Great, thanks! I'll look into it. This might be the final push to get him to join in with me in learning to use Linux.

    thanks

  4. #4
    Join Date
    Aug 2008
    Location
    Washington DC
    Beans
    2,186
    Distro
    Ubuntu 11.04 Natty Narwhal

    Re: Colour-blind: colours in Command Line output

    Code:
    alias ls='ls --color=auto'
    is in the .bashrc file

    just remove the line.

    on per case basis -- bypass the alias with a "\"

    ie.

    Code:
    \ls -l

  5. #5
    Join Date
    Aug 2012
    Beans
    76

    Re: Colour-blind: colours in Command Line output

    This will only make the background white and the foreground black.

    From profile preferences click on colours and check "use colours from system theme" until it has no tick. Next, click on built-in-schemes select black on white or white on black.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •