Results 1 to 4 of 4

Thread: Compiz stopped working with upgrade to Precise (Mobility radeon 7000)

  1. #1
    Join Date
    Mar 2007
    Beans
    Hidden!

    Compiz stopped working with upgrade to Precise (Mobility radeon 7000)

    I upgraded a Dell C610 from Ubuntu Lucid to Xubuntu Precise. Compiz worked just fine under Lucid, but I can't seem to get it to work under Precise. I didn't think to check what driver I was using under Lucid.

    I downloaded a script called compiz-check which said "The vesa driver is not capable of running Compiz, you need to install the proper driver for your graphics card."

    The AMD support site doesn't list Mobility 7000 in it's driver list. There's a HD 7000, but I'm not sure that's the same.

    I went to the how to at https://help.ubuntu.com/community/BinaryDriverHowto/ATI, and tried to install the fglrx driver, but all that did was clobber my login screen.

    So, is Compiz not possible with my hardware under Precise? Why the difference between Lucid and Precise? Maybe I was using a proprietary driver?

    Oh, and lspci | grep VGA gives:
    01:00.0 VGA compatible controller [0300]: Advanced Micro Devices [AMD] nee ATI RV100 LY [Mobility Radeon 7000] [1002:4c59]

  2. #2
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: Compiz stopped working with upgrade to Precise (Mobility radeon 7000)

    **** BUMP *****

    Anyone? Seriously? I'm completely at a loss here.

  3. #3
    Join Date
    Jul 2008
    Location
    The Left Coast of the USA
    Beans
    Hidden!
    Distro
    Kubuntu

    Re: Compiz stopped working with upgrade to Precise (Mobility radeon 7000)

    What do you mean by "clobber my login screen"?

    That looks like a "legacy" card, by the way, and the current ATI driver will not work.

    The legacy driver will not work with X post 2008. You'll need to use the default Radeon driver and we'll have to sort out why Compiz isn't working.
    Last edited by QIII; September 22nd, 2012 at 07:07 AM.
    The Community Java Wiki * The Community ATI Driver Wiki * Find what you need in the Ubuntu Community wikis

    And seeing the terror on the faces of the people, QIII did speak to them, saying "Fear not the Terminal, for it is a road both swift and secure to the Great Mysteries of Linux without passing through the dangers of The Land of Ten Thousand Competing Desktop Environments."

  4. #4
    Join Date
    Mar 2007
    Beans
    Hidden!

    Re: Compiz stopped working with upgrade to Precise (Mobility radeon 7000)

    QIII: Thanks for the reply!

    Sorry, I guess "clobber" wasn't very descriptive. I have an encrypted LVM disk setup and when in installed the fglx driver, the pretty blue screen prompting me for a password to unlock the disk turned in to a terminal based password prompt. It doesn't really matter to me, but I thought it was curious behavior worth reporting. Removing the fglx driver has returned the "enter password" screen back to normal.

    Doing an lspci -k gives me:
    Code:
    01:00.0 VGA compatible controller: Advanced Micro Devices [AMD] nee ATI RV100 LY [Mobility Radeon 7000]
    	Subsystem: Dell Device 00e3
    	Kernel driver in use: radeon
    	Kernel modules: radeon, radeonfb
    So it seems that I am using the radeon driver, yet I ran the compiz-check script again and it still thinks I'm using vesa.

    This is a pretty old laptop, so I'm not suprised it's a legacy card. If you could let me know what info to post or troubleshooting to run, I'll do it. In the meantime, I'll keep searching the forums. Thanks!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •