Results 1 to 10 of 10

Thread: pwr button in VirtualBox

  1. #1
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,829
    Distro
    Ubuntu 13.04 Raring Ringtail

    Super key in VirtualBox

    Say, for example, I'm running Linux Mint in VirtualBox installed from the repos on Ubuntu 12.04.

    Everything works great with one exception. When I hit the pwr key to bring up the Mate equivalent of the Dash (not sure what it's called), The Dash also comes up on the host computer, over the top of the VM. I would have thought VirtualBox would prevent that keystroke from getting through to the host machine, but apparently not. Can I change this?
    Last edited by newb85; September 15th, 2012 at 04:37 AM.
    Jane, stop this crazy thing!

  2. #2
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,829
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: pwr button in VirtualBox

    Is there really no one else using VirtualBox with Unity on their host machine who can confirm or deny that they are also experiencing this?
    Jane, stop this crazy thing!

  3. #3
    Join Date
    Apr 2007
    Beans
    606
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: pwr button in VirtualBox

    happens to me all the time, have no clue how to fix it

  4. #4
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,829
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: pwr button in VirtualBox

    I just realized that I've been saying "pwr button" when I mean "Super Key". Perhaps that's why I've had so few hits on this thread...

    I can still edit my initial post, but is it possible to change the thread title?
    Jane, stop this crazy thing!

  5. #5
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: pwr button in VirtualBox

    Same thing happens on Windows machines if you have guest additions installed and have it set so the keyboard isn't "locked" to the VM.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  6. #6
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,829
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: pwr button in VirtualBox

    I'm not sure what you mean by "locked to the VM". I have VirtualBox set to auto capture the keyboard. The description VirtualBox gives of that option is:

    When checked, the keyboard is automatically captured every time the VM window is activated. When the keyboard is captured, all keystrokes (including system ones, like Alt-Tab) are directed to the VM.
    The behavior I'm observing is inconsistent with this description. Methinks I should be filing a bug report...
    Jane, stop this crazy thing!

  7. #7
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: pwr button in VirtualBox

    Do you have the guest additions installed?

    If you don't have them installed, the VM "grabs" the keyboard and mouse and alt+tab + super key and whatnot work fine, but if you have them installed, it is integrated into the host system.

    There should be a button to send the super key to the VM tho.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  8. #8
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,829
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: pwr button in VirtualBox

    Quote Originally Posted by CharlesA View Post
    Do you have the guest additions installed?

    If you don't have them installed, the VM "grabs" the keyboard and mouse and alt+tab + super key and whatnot work fine, but if you have them installed, it is integrated into the host system.
    Hmm...I didn't specifically install them, but I pulled up "Additional Drivers" in Mint, and sure enough, they're installed and activated.

    So, why would guest additions integrate Super into the host system? I guess I don't fully understand the point of guest additions. I know that it fixes resolution issues, but that has nothing to do with Super...

    Quote Originally Posted by CharlesA View Post
    There should be a button to send the super key to the VM tho.
    Where is this button exactly? It's certainly not in the same place as the Auto Capture option.
    Jane, stop this crazy thing!

  9. #9
    Join Date
    Oct 2009
    Beans
    Hidden!
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: pwr button in VirtualBox

    I must be thinking of something else. Try disabling mouse integration and see what happens.
    Come to #ubuntuforums! We have cookies! | Basic Ubuntu Security Guide

    Tomorrow's an illusion and yesterday's a dream, today is a solution...

  10. #10
    Join Date
    May 2009
    Location
    Indiana
    Beans
    1,829
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: pwr button in VirtualBox

    No change...
    Jane, stop this crazy thing!

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •