Results 1 to 7 of 7

Thread: 10.04 LTS to 12.04.1 LTS: "Could not calculate the upgrade"

  1. #1
    Join Date
    Apr 2006
    Location
    Seine-et-Oise,France
    Beans
    397
    Distro
    Ubuntu 12.04 Precise Pangolin

    10.04 LTS to 12.04.1 LTS: "Could not calculate the upgrade"

    I'm trying to upgrade from 10.04 LTS to 12.04.1 LTS using the upgrade manager, and I get the following message.

    Code:
    Could not calculate the upgrade
    
    An unresolvable problem occurred while calculating the upgrade:
    E:Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.
    
     This can be caused by:
     * Upgrading to a pre-release version of Ubuntu
     * Running the current pre-release version of Ubuntu
     * Unofficial software packages not provided by Ubuntu
    
    If none of this applies, then please report this bug using the command 'ubuntu-bug update-manager' in a terminal.

    I read a couple of threads about this problem on Launchpad, so here is output from trying to upgrade in a terminal window.

    Code:
    $ sudo apt-get update
    Hit http://archive.canonical.com lucid Release.gpg
    Ign http://archive.canonical.com/ubuntu/ lucid/partner Translation-en_US                                                           
    Hit http://ppa.launchpad.net lucid Release.gpg                                                                                     
    Ign http://ppa.launchpad.net/ubuntu-hams-updates/ppa/ubuntu/ lucid/main Translation-en_US                                          
    Hit http://security.ubuntu.com lucid-security Release.gpg                                                                          
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/main Translation-en_US                                                       
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/restricted Translation-en_US                                                 
    Hit http://archive.canonical.com lucid Release                                                                                     
    Hit http://ppa.launchpad.net lucid Release                                                                                         
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/universe Translation-en_US           
    Ign http://security.ubuntu.com/ubuntu/ lucid-security/multiverse Translation-en_US         
    Hit http://security.ubuntu.com lucid-security Release                                      
    Hit http://archive.canonical.com lucid/partner Sources                                                           
    Hit http://ppa.launchpad.net lucid/main Packages                                           
    Hit http://security.ubuntu.com lucid-security/main Packages                                
    Hit http://archive.canonical.com lucid/partner Packages                                    
    Hit http://us.archive.ubuntu.com lucid Release.gpg                   
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid/main Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid/restricted Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid/universe Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid/multiverse Translation-en_US
    Get:1 http://us.archive.ubuntu.com lucid-updates Release.gpg [198B]  
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/main Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/restricted Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/universe Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid-updates/multiverse Translation-en_US
    Hit http://security.ubuntu.com lucid-security/restricted Packages
    Hit http://security.ubuntu.com lucid-security/main Sources
    Hit http://security.ubuntu.com lucid-security/restricted Sources
    Hit http://security.ubuntu.com lucid-security/universe Packages
    Hit http://security.ubuntu.com lucid-security/universe Sources
    Hit http://security.ubuntu.com lucid-security/multiverse Packages    
    Ign http://debian.slimdevices.com stable Release.gpg                 
    Hit http://security.ubuntu.com lucid-security/multiverse Sources     
    Get:2 http://us.archive.ubuntu.com lucid-proposed Release.gpg [198B]
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid-proposed/restricted Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid-proposed/main Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid-proposed/multiverse Translation-en_US
    Ign http://us.archive.ubuntu.com/ubuntu/ lucid-proposed/universe Translation-en_US
    Hit http://us.archive.ubuntu.com lucid Release 
    Get:3 http://us.archive.ubuntu.com lucid-updates Release [58.3kB]    
    Ign http://debian.slimdevices.com/ stable/main Translation-en_US           
    Hit http://debian.slimdevices.com stable Release     
    Get:4 http://us.archive.ubuntu.com lucid-proposed Release [58.3kB]
    Ign http://debian.slimdevices.com stable/main Packages                    
    Hit http://us.archive.ubuntu.com lucid/main Packages   
    Hit http://us.archive.ubuntu.com lucid/restricted Packages
    Hit http://us.archive.ubuntu.com lucid/main Sources
    Hit http://us.archive.ubuntu.com lucid/restricted Sources
    Hit http://us.archive.ubuntu.com lucid/universe Packages
    Hit http://us.archive.ubuntu.com lucid/universe Sources
    Hit http://us.archive.ubuntu.com lucid/multiverse Packages
    Hit http://us.archive.ubuntu.com lucid/multiverse Sources
    Hit http://us.archive.ubuntu.com lucid-updates/main Packages
    Hit http://us.archive.ubuntu.com lucid-updates/restricted Packages
    Hit http://us.archive.ubuntu.com lucid-updates/main Sources
    Hit http://us.archive.ubuntu.com lucid-updates/restricted Sources
    Hit http://us.archive.ubuntu.com lucid-updates/universe Packages
    Hit http://us.archive.ubuntu.com lucid-updates/universe Sources
    Hit http://us.archive.ubuntu.com lucid-updates/multiverse Packages
    Hit http://us.archive.ubuntu.com lucid-updates/multiverse Sources
    Ign http://debian.slimdevices.com stable/main Packages
    Hit http://us.archive.ubuntu.com lucid-proposed/restricted Packages
    Hit http://us.archive.ubuntu.com lucid-proposed/main Packages
    Hit http://us.archive.ubuntu.com lucid-proposed/multiverse Packages
    Hit http://us.archive.ubuntu.com lucid-proposed/universe Packages
    Hit http://debian.slimdevices.com stable/main Packages
    Fetched 117kB in 1s (79.3kB/s)
    Reading package lists... Done
    klrhodes@mercury:~$ sudo apt-get upgrade
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    
    
    
    $ dpkg -l | awk {'print $2'}| grep -i desktop
    desktop-file-utils
    desktopcouch
    gnome-desktop-data
    libdesktopcouch-glib-1.0-2
    libgnome-desktop-2-11
    libgnome-desktop-2-17
    libgnome-desktop-2-7
    policykit-desktop-privileges
    python-desktopcouch
    python-desktopcouch-records
    rdesktop
    shared-desktop-ontologies
    ubuntu-desktop
    Can anybody help me understand what is the cause of the problem?

    K.
    Ubuntu 12.04LTS Intel Q9650 SLB8W @ 3.0GHz :: 8 GByte RAM
    640 GBytes of discs :: DVD burner :: BluRay burner
    Mixed ethernet, WiFi and CPL networking :: 2 TByte NAS :: Network Printing :: Raspbian and MacOS

  2. #2
    Join Date
    Jun 2007
    Location
    K-o-T,
    Beans
    Hidden!
    Distro
    Ubuntu Development Release

    Re: 10.04 LTS to 12.04.1 LTS: "Could not calculate the upgrade"

    * Unofficial software packages not provided by Ubuntu
    Do you have any third party PPA's or repositories that are still enabled?


    e.g.Hit http://debian.slimdevices.com stable/main Packages

    Try disabling all the third party repositories and then also run
    Code:
    sudo apt-get dist-upgrade
    to see if there are any updates still to be installed and not held back.

    Then try the "update-manager -d" again.

    Good Luck
    Hypertension = Take with a pinch of salt
    | Psychocats | Ubuntu Documentation | Howto [Solved] | BBcode list | Brother Website |

  3. #3
    Join Date
    Apr 2006
    Location
    Seine-et-Oise,France
    Beans
    397
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 10.04 LTS to 12.04.1 LTS: "Could not calculate the upgrade"

    Quote Originally Posted by plucky View Post
    Do you have any third party PPA's or repositories that are still enabled?


    e.g.Hit http://debian.slimdevices.com stable/main Packages

    Try disabling all the third party repositories and then also run
    Code:
    sudo apt-get dist-upgrade
    to see if there are any updates still to be installed and not held back.

    Then try the "update-manager -d" again.

    Good Luck
    Thanks for the hint. I'd already tried again, with all third pary sources disabled, and that changed nothing. I just tried detecting a better server (I moved from the US to France a couple of weeks ago), and tried again... still getting the same "Could not calculate the upgrade" message.

    I took a look at the options in the "Updates" tab of the "Software Sources" dialog in the "Update Manager": I have three options checked for "Ubuntu updates":
    • Important security updates (lucid-security)
    • Recommended updates (lucid-updates)
    • Pre-released updates (lucid-proposed)

    and then one unchecked:
    • Unsupported updates (lucid-backports).


    Part of the message I'm getting from the Update Manager mentions "pre-released" versions, so I'll try unchecking that option.

    K.
    Ubuntu 12.04LTS Intel Q9650 SLB8W @ 3.0GHz :: 8 GByte RAM
    640 GBytes of discs :: DVD burner :: BluRay burner
    Mixed ethernet, WiFi and CPL networking :: 2 TByte NAS :: Network Printing :: Raspbian and MacOS

  4. #4
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

    Re: 10.04 LTS to 12.04.1 LTS: "Could not calculate the upgrade"

    You don't have the headroom? Guessing the partition you have 10.04 LTS on is almost full. Upgrade needs space to download and store a lot of stuff which is later deleted. If you have 10.04 on a 15Gb partition and are using 13Gb, say, you have little chance. I could be wrong but that's a stab. Had something similar awhile back with same message.

    Best to uncheck everything except the main tab. Doubt that is the issue though.
    Last edited by Bucky Ball; September 13th, 2012 at 12:23 PM.

  5. #5
    Join Date
    Apr 2006
    Location
    Seine-et-Oise,France
    Beans
    397
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 10.04 LTS to 12.04.1 LTS: "Could not calculate the upgrade"

    Quote Originally Posted by Bucky Ball View Post
    You don't have the headroom. Guessing the partition you have 10.04 LTS on is almost full. Upgrade needs space to download and store a lot of stuff which is later deleted. If you have 10.04 on a 15Gb partition and are using 13Gb, say, you have little chance.

    I could be wrong but that's a stab.
    I have 23.3 GiB available on a 70.5 GiB ext3 filesystem...

    I've seen some crazy error messages from software, but I would have though that it would be simple to calculate the amount of space required for downloading the packages and give a meaningful message if there was not enough space available on the filesystem.

    K.
    Ubuntu 12.04LTS Intel Q9650 SLB8W @ 3.0GHz :: 8 GByte RAM
    640 GBytes of discs :: DVD burner :: BluRay burner
    Mixed ethernet, WiFi and CPL networking :: 2 TByte NAS :: Network Printing :: Raspbian and MacOS

  6. #6
    Join Date
    Feb 2008
    Location
    Planet earth, for now.
    Beans
    Hidden!
    Distro
    Xubuntu

  7. #7
    Join Date
    Apr 2006
    Location
    Seine-et-Oise,France
    Beans
    397
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: 10.04 LTS to 12.04.1 LTS: "Could not calculate the upgrade"

    Quote Originally Posted by Bucky Ball View Post
    Got ya. So your / partition = 70Gb?
    That's correct.

    I did a bit more poking around and found some logs, I wonder if this is useful?

    Code:
    $ more /var/log/dist-upgrade/20120913-1320/main_pre_req.log 
    2012-09-13 13:20:07,803 INFO Using config files '['./DistUpgrade.cfg.lucid']'
    2012-09-13 13:20:07,803 INFO uname information: 'Linux mercury 2.6.32-43-generic #97-Ubuntu SMP Wed Sep 5 16:43:09 UTC 2012 i686'
    2012-09-13 13:20:07,803 INFO apt version: '0.7.25.3ubuntu9.14'
    2012-09-13 13:20:07,803 INFO release-upgrader version '0.156.14.9' started
    2012-09-13 13:20:08,071 DEBUG svg pixbuf loader failed (Error displaying image)
    2012-09-13 13:20:08,303 DEBUG Using 'DistUpgradeViewGtk' view
    2012-09-13 13:20:08,355 DEBUG aufsOptionsAndEnvironmentSetup()
    2012-09-13 13:20:08,379 DEBUG using '/tmp/upgrade-rw-sED0ss' as aufs_rw_dir
    2012-09-13 13:20:08,380 DEBUG using '/tmp/upgrade-chroot-VMiRXz' as aufs chroot dir
    2012-09-13 13:20:08,381 DEBUG enable dpkg --force-overwrite
    2012-09-13 13:20:08,412 DEBUG creating statefile: '/var/log/dist-upgrade/apt-clone_system_state.tar.gz'
    2012-09-13 13:20:14,043 DEBUG lsb-release: 'lucid'
    2012-09-13 13:20:14,045 DEBUG _pythonSymlinkCheck run
    2012-09-13 13:20:14,045 DEBUG openCache()
    2012-09-13 13:20:14,045 DEBUG Plugin modules in ./plugins: remove_lilo_plugin.py langpack_manual_plugin.py dpkg_status_plugin.py kdelibs4to5_plugin.py deb_plug
    in.py
    2012-09-13 13:20:14,046 DEBUG Loading module ./plugins/remove_lilo_plugin.py
    2012-09-13 13:20:14,048 DEBUG Plugins in <module 'remove_lilo_plugin' from './plugins/remove_lilo_plugin.py'>: <class 'remove_lilo_plugin.RemoveLiloPlugin'>
    2012-09-13 13:20:14,048 DEBUG Loading module ./plugins/langpack_manual_plugin.py
    2012-09-13 13:20:14,050 DEBUG Plugins in <module 'langpack_manual_plugin' from './plugins/langpack_manual_plugin.py'>: <class 'langpack_manual_plugin.MarkLangp
    acksManuallyInstalledPlugin'>
    2012-09-13 13:20:14,050 DEBUG Loading module ./plugins/dpkg_status_plugin.py
    2012-09-13 13:20:14,052 DEBUG Plugins in <module 'dpkg_status_plugin' from './plugins/dpkg_status_plugin.py'>: <class 'dpkg_status_plugin.DpkgStatusPlugin'>
    2012-09-13 13:20:14,052 DEBUG Loading module ./plugins/kdelibs4to5_plugin.py
    2012-09-13 13:20:14,054 DEBUG Plugins in <module 'kdelibs4to5_plugin' from './plugins/kdelibs4to5_plugin.py'>: <class 'kdelibs4to5_plugin.Kdelibs4devToKdelibs5
    devPlugin'>
    2012-09-13 13:20:14,054 DEBUG Loading module ./plugins/deb_plugin.py
    2012-09-13 13:20:14,055 DEBUG Plugins in <module 'deb_plugin' from './plugins/deb_plugin.py'>: <class 'deb_plugin.DebPlugin'>
    2012-09-13 13:20:14,055 DEBUG plugins for condition 'PreCacheOpen' are '[]'
    2012-09-13 13:20:14,055 DEBUG plugins for condition 'precisePreCacheOpen' are '[]'
    2012-09-13 13:20:14,056 DEBUG plugins for condition 'from_lucidPreCacheOpen' are '[]'
    2012-09-13 13:20:14,056 DEBUG quirks: running PreCacheOpen
    2012-09-13 13:20:14,056 DEBUG running Quirks.PreCacheOpen
    2012-09-13 13:20:14,645 DEBUG /openCache(), new cache size 31341
    2012-09-13 13:20:14,645 DEBUG needServerMode(): run in 'desktop' mode, (because of pkg 'ubuntu-desktop')
    2012-09-13 13:20:14,646 DEBUG checkViewDepends()
    2012-09-13 13:20:14,646 DEBUG need backports
    2012-09-13 13:20:14,646 DEBUG getRequiredBackports()
    2012-09-13 13:20:14,647 DEBUG writing prerequists sources.list at: '/etc/apt/sources.list.d/prerequists-sources.list' 
    2012-09-13 13:20:14,765 DEBUG adding '# sources.list fragment for pre-requists (mirror from sources.list + fallback)
    ' prerequists
    2012-09-13 13:20:14,765 DEBUG adding '# this is safe to remove after the upgrade
    ' prerequists
    2012-09-13 13:20:14,765 DEBUG adding 'deb http://ftp.oleane.net/ubuntu/ lucid-updates main
    
    ' prerequists
    2012-09-13 13:20:14,765 DEBUG adding '# when this changes from -proposed to -updates, ensure to update
    ' prerequists
    2012-09-13 13:20:14,765 DEBUG adding '# DistUpgradeController.py:1393 as well
    ' prerequists
    2012-09-13 13:20:14,765 DEBUG adding 'deb http://archive.ubuntu.com/ubuntu/ lucid-updates main
    ' prerequists
    2012-09-13 13:20:14,766 DEBUG running doUpdate() (showErrors=False)
    2012-09-13 13:20:18,914 DEBUG openCache()
    2012-09-13 13:20:25,676 DEBUG /openCache(), new cache size 31341
    2012-09-13 13:20:25,683 DEBUG marking 'libapt-pkg4.12' for install
    2012-09-13 13:20:25,735 DEBUG marking 'libapt-inst1.4' for install
    2012-09-13 13:20:25,785 DEBUG marking 'release-upgrader-python-apt' for install
    2012-09-13 13:20:25,834 INFO cache.commit()
    2012-09-13 13:20:25,834 DEBUG failed to SystemUnLock() (E:Not locked)
    K.
    Ubuntu 12.04LTS Intel Q9650 SLB8W @ 3.0GHz :: 8 GByte RAM
    640 GBytes of discs :: DVD burner :: BluRay burner
    Mixed ethernet, WiFi and CPL networking :: 2 TByte NAS :: Network Printing :: Raspbian and MacOS

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •