Page 1 of 2 12 LastLast
Results 1 to 10 of 15

Thread: trying to install HeeksCNC and having trouble (See Pastes from Terminal)

  1. #1
    Join Date
    Aug 2012
    Beans
    286

    trying to install HeeksCNC and having trouble (See Pastes from Terminal)

    I went through the steps from this instruction set:
    http://code.google.com/p/heekscad/wi...tuInstallation

    and in the Terminal I end up with this at this step in the process:
    -- Build files have been written to: /home/nick/heekscad
    nick@NickUbuntu:~/heekscad$ make package
    make: *** No rule to make target `package'. Stop.
    nick@NickUbuntu:~/heekscad$ sudo dpkg -i heekscad_*.deb
    [sudo] password for nick:
    dpkg: error processing heekscad_*.deb (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    heekscad_*.deb

    Being a new Ubuntu user, I have no idea where to look.

  2. #2
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,828
    Distro
    Ubuntu Development Release

    Re: trying to install HeeksCNC and having trouble (See Pastes from Terminal)

    Code:
    nick@NickUbuntu:~/heekscad$ make package
    make: *** No rule to make target `package'.  Stop.
    here is the area of errors , this is the process have to be success .
    Raja

    రాజ శేఖర్ రెడ్డి

  3. #3
    Join Date
    Aug 2012
    Beans
    286

    Re: trying to install HeeksCNC and having trouble (See Pastes from Terminal)

    Quote Originally Posted by raja.genupula View Post
    Code:
    nick@NickUbuntu:~/heekscad$ make package
    make: *** No rule to make target `package'.  Stop.
    here is the area of errors , this is the process have to be success .
    I understood this but I don't know how to make it work. Any tips?

  4. #4
    Join Date
    Nov 2010
    Location
    India
    Beans
    4,828
    Distro
    Ubuntu Development Release

    Re: trying to install HeeksCNC and having trouble (See Pastes from Terminal)

    Ok post here the total process of what you have done and what you got . Then we can help you by finding where is the exact mistake .
    Raja

    రాజ శేఖర్ రెడ్డి

  5. #5
    Join Date
    Aug 2012
    Beans
    286

    Re: trying to install HeeksCNC and having trouble (See Pastes from Terminal)

    Quote Originally Posted by raja.genupula View Post
    Ok post here the total process of what you have done and what you got . Then we can help you by finding where is the exact mistake .
    Sure, here is that. Also, I believe I just followed the steps in that article (at least I tried to ).
    nick@NickUbuntu:~$ sudo apt-get install git subversion libwxbase2.8-dev cmake build-essential libopencascade-dev libwxgtk2.8-dev libgtkglext1-dev python-dev cmake libboost-python-dev libgtkglext1-dev python-dev cma[sudo] password for nick:
    Reading package lists... Done
    Building dependency tree
    Reading state information... Done
    cmake is already the newest version.
    git is already the newest version.
    subversion is already the newest version.
    libgtkglext1-dev is already the newest version.
    The following packages were automatically installed and are no longer required:
    language-pack-zh-hans language-pack-kde-en language-pack-kde-zh-hans language-pack-kde-en-base kde-l10n-engb kde-l10n-zhcn
    language-pack-zh-hans-base language-pack-kde-zh-hans-base amarok-help-en
    Use 'apt-get autoremove' to remove them.
    The following extra packages will be installed:
    gccxml libboost-python1.46-dev libboost-python1.46.1 libboost1.46-dev libftgl2 libopencascade-foundation-6.5.0
    libopencascade-foundation-dev libopencascade-modeling-6.5.0 libopencascade-modeling-dev libopencascade-ocaf-6.5.0
    libopencascade-ocaf-dev libopencascade-ocaf-lite-6.5.0 libopencascade-ocaf-lite-dev libopencascade-visualization-6.5.0
    libopencascade-visualization-dev libssl-dev libssl-doc python2.7-dev wx-common wx2.8-headers
    Suggested packages:
    libboost1.46-doc python3 libboost-date-time1.46-dev libboost-filesystem1.46-dev libboost-graph1.46-dev libboost-iostreams1.46-dev
    libboost-math1.46-dev libboost-program-options1.46-dev libboost-random1.46-dev libboost-regex1.46-dev
    libboost-serialization1.46-dev libboost-signals1.46-dev libboost-system1.46-dev libboost-test1.46-dev libboost-thread1.46-dev
    libboost-wave1.46-dev xsltproc doxygen default-jdk fop opencascade-doc wx2.8-doc
    The following NEW packages will be installed:
    gccxml libboost-python-dev libboost-python1.46-dev libboost-python1.46.1 libboost1.46-dev libftgl2 libopencascade-dev
    libopencascade-foundation-6.5.0 libopencascade-foundation-dev libopencascade-modeling-6.5.0 libopencascade-modeling-dev
    libopencascade-ocaf-6.5.0 libopencascade-ocaf-dev libopencascade-ocaf-lite-6.5.0 libopencascade-ocaf-lite-dev
    libopencascade-visualization-6.5.0 libopencascade-visualization-dev libssl-dev libssl-doc libwxbase2.8-dev libwxgtk2.8-dev
    python-dev python2.7-dev wx-common wx2.8-headers
    The following packages will be upgraded:
    build-essential
    1 upgraded, 25 newly installed, 0 to remove and 9 not upgraded.
    Need to get 75.3 MB of archives.
    After this operation, 227 MB of additional disk space will be used.
    Do you want to continue [Y/n]? Y
    Get:1 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main build-essential i386 11.5ubuntu2.1 [5,796 B]
    Get:2 http://us.archive.ubuntu.com/ubuntu/ precise/main gccxml i386 0.9.0+cvs20111013-1 [3,966 kB]
    Get:3 http://us.archive.ubuntu.com/ubuntu/ precise/main libboost1.46-dev i386 1.46.1-7ubuntu3 [7,641 kB]
    Get:4 http://us.archive.ubuntu.com/ubuntu/ precise/main libboost-python1.46.1 i386 1.46.1-7ubuntu3 [226 kB]
    Get:5 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main libssl-dev i386 1.0.1-4ubuntu5.5 [1,420 kB]
    Get:6 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main python2.7-dev i386 2.7.3-0ubuntu3.1 [29.2 MB]
    Get:7 http://us.archive.ubuntu.com/ubuntu/ precise/main python-dev i386 2.7.3-0ubuntu2 [1,084 B]
    Get:8 http://us.archive.ubuntu.com/ubuntu/ precise/main libboost-python1.46-dev i386 1.46.1-7ubuntu3 [314 kB]
    Get:9 http://us.archive.ubuntu.com/ubuntu/ precise/main libboost-python-dev i386 1.48.0.2 [3,100 B]
    Get:10 http://us.archive.ubuntu.com/ubuntu/ precise/universe libftgl2 i386 2.1.3~rc5-4 [62.5 kB]
    Get:11 http://us.archive.ubuntu.com/ubuntu/ precise-updates/main libssl-doc all 1.0.1-4ubuntu5.5 [1,034 kB]
    Get:12 http://us.archive.ubuntu.com/ubuntu/ precise/universe wx2.8-headers i386 2.8.12.1-6ubuntu2 [1,485 kB]
    Get:13 http://us.archive.ubuntu.com/ubuntu/ precise/universe libwxbase2.8-dev i386 2.8.12.1-6ubuntu2 [31.2 kB]
    Get:14 http://us.archive.ubuntu.com/ubuntu/ precise/universe wx-common i386 2.8.12.1-6ubuntu2 [52.9 kB]
    Get:15 http://us.archive.ubuntu.com/ubuntu/ precise/universe libwxgtk2.8-dev i386 2.8.12.1-6ubuntu2 [31.5 kB]
    Get:16 http://us.archive.ubuntu.com/ubuntu/ precise/universe libopencascade-foundation-6.5.0 i386 6.5.0.dfsg-2build1 [1,478 kB]
    Get:17 http://us.archive.ubuntu.com/ubuntu/ precise/universe libopencascade-foundation-dev all 6.5.0.dfsg-2build1 [1,199 kB]
    Get:18 http://us.archive.ubuntu.com/ubuntu/ precise/universe libopencascade-modeling-6.5.0 i386 6.5.0.dfsg-2build1 [14.5 MB]
    Get:19 http://us.archive.ubuntu.com/ubuntu/ precise/universe libopencascade-modeling-dev all 6.5.0.dfsg-2build1 [3,479 kB]
    Get:20 http://us.archive.ubuntu.com/ubuntu/ precise/universe libopencascade-ocaf-lite-6.5.0 i386 6.5.0.dfsg-2build1 [1,633 kB]
    Get:21 http://us.archive.ubuntu.com/ubuntu/ precise/universe libopencascade-ocaf-lite-dev all 6.5.0.dfsg-2build1 [557 kB]
    Get:22 http://us.archive.ubuntu.com/ubuntu/ precise/universe libopencascade-visualization-6.5.0 i386 6.5.0.dfsg-2build1 [4,818 kB]
    Get:23 http://us.archive.ubuntu.com/ubuntu/ precise/universe libopencascade-ocaf-6.5.0 i386 6.5.0.dfsg-2build1 [1,009 kB]
    Get:24 http://us.archive.ubuntu.com/ubuntu/ precise/universe libopencascade-ocaf-dev all 6.5.0.dfsg-2build1 [174 kB]
    Get:25 http://us.archive.ubuntu.com/ubuntu/ precise/universe libopencascade-visualization-dev all 6.5.0.dfsg-2build1 [889 kB]
    Get:26 http://us.archive.ubuntu.com/ubuntu/ precise/universe libopencascade-dev all 6.5.0.dfsg-2build1 [8,266 B]
    Fetched 75.3 MB in 23min 19s (53.8 kB/s)
    (Reading database ... 216616 files and directories currently installed.)
    Preparing to replace build-essential 11.5ubuntu2 (using .../build-essential_11.5ubuntu2.1_i386.deb) ...
    Unpacking replacement build-essential ...
    Selecting previously unselected package gccxml.
    Unpacking gccxml (from .../gccxml_0.9.0+cvs20111013-1_i386.deb) ...
    Selecting previously unselected package libboost1.46-dev.
    Unpacking libboost1.46-dev (from .../libboost1.46-dev_1.46.1-7ubuntu3_i386.deb) ...
    Selecting previously unselected package libboost-python1.46.1.
    Unpacking libboost-python1.46.1 (from .../libboost-python1.46.1_1.46.1-7ubuntu3_i386.deb) ...
    Selecting previously unselected package libssl-dev.
    Unpacking libssl-dev (from .../libssl-dev_1.0.1-4ubuntu5.5_i386.deb) ...
    Selecting previously unselected package python2.7-dev.
    Unpacking python2.7-dev (from .../python2.7-dev_2.7.3-0ubuntu3.1_i386.deb) ...
    Selecting previously unselected package python-dev.
    Unpacking python-dev (from .../python-dev_2.7.3-0ubuntu2_i386.deb) ...
    Selecting previously unselected package libboost-python1.46-dev.
    Unpacking libboost-python1.46-dev (from .../libboost-python1.46-dev_1.46.1-7ubuntu3_i386.deb) ...
    Selecting previously unselected package libboost-python-dev.
    Unpacking libboost-python-dev (from .../libboost-python-dev_1.48.0.2_i386.deb) ...
    Selecting previously unselected package libftgl2.
    Unpacking libftgl2 (from .../libftgl2_2.1.3~rc5-4_i386.deb) ...
    Selecting previously unselected package libssl-doc.
    Unpacking libssl-doc (from .../libssl-doc_1.0.1-4ubuntu5.5_all.deb) ...
    Selecting previously unselected package wx2.8-headers.
    Unpacking wx2.8-headers (from .../wx2.8-headers_2.8.12.1-6ubuntu2_i386.deb) ...
    Selecting previously unselected package libwxbase2.8-dev.
    Unpacking libwxbase2.8-dev (from .../libwxbase2.8-dev_2.8.12.1-6ubuntu2_i386.deb) ...
    Selecting previously unselected package wx-common.
    Unpacking wx-common (from .../wx-common_2.8.12.1-6ubuntu2_i386.deb) ...
    Selecting previously unselected package libwxgtk2.8-dev.
    Unpacking libwxgtk2.8-dev (from .../libwxgtk2.8-dev_2.8.12.1-6ubuntu2_i386.deb) ...
    Selecting previously unselected package libopencascade-foundation-6.5.0.
    Unpacking libopencascade-foundation-6.5.0 (from .../libopencascade-foundation-6.5.0_6.5.0.dfsg-2build1_i386.deb) ...
    Selecting previously unselected package libopencascade-foundation-dev.
    Unpacking libopencascade-foundation-dev (from .../libopencascade-foundation-dev_6.5.0.dfsg-2build1_all.deb) ...
    Selecting previously unselected package libopencascade-modeling-6.5.0.
    Unpacking libopencascade-modeling-6.5.0 (from .../libopencascade-modeling-6.5.0_6.5.0.dfsg-2build1_i386.deb) ...
    Selecting previously unselected package libopencascade-modeling-dev.
    Unpacking libopencascade-modeling-dev (from .../libopencascade-modeling-dev_6.5.0.dfsg-2build1_all.deb) ...
    Selecting previously unselected package libopencascade-ocaf-lite-6.5.0.
    Unpacking libopencascade-ocaf-lite-6.5.0 (from .../libopencascade-ocaf-lite-6.5.0_6.5.0.dfsg-2build1_i386.deb) ...
    Selecting previously unselected package libopencascade-ocaf-lite-dev.
    Unpacking libopencascade-ocaf-lite-dev (from .../libopencascade-ocaf-lite-dev_6.5.0.dfsg-2build1_all.deb) ...
    Selecting previously unselected package libopencascade-visualization-6.5.0.
    Unpacking libopencascade-visualization-6.5.0 (from .../libopencascade-visualization-6.5.0_6.5.0.dfsg-2build1_i386.deb) ...
    Selecting previously unselected package libopencascade-ocaf-6.5.0.
    Unpacking libopencascade-ocaf-6.5.0 (from .../libopencascade-ocaf-6.5.0_6.5.0.dfsg-2build1_i386.deb) ...
    Selecting previously unselected package libopencascade-ocaf-dev.
    Unpacking libopencascade-ocaf-dev (from .../libopencascade-ocaf-dev_6.5.0.dfsg-2build1_all.deb) ...
    Selecting previously unselected package libopencascade-visualization-dev.
    Unpacking libopencascade-visualization-dev (from .../libopencascade-visualization-dev_6.5.0.dfsg-2build1_all.deb) ...
    Selecting previously unselected package libopencascade-dev.
    Unpacking libopencascade-dev (from .../libopencascade-dev_6.5.0.dfsg-2build1_all.deb) ...
    Processing triggers for man-db ...
    Setting up build-essential (11.5ubuntu2.1) ...
    Setting up gccxml (0.9.0+cvs20111013-1) ...
    Setting up libboost1.46-dev (1.46.1-7ubuntu3) ...
    Setting up libboost-python1.46.1 (1.46.1-7ubuntu3) ...
    Setting up libssl-dev (1.0.1-4ubuntu5.5) ...
    Setting up python2.7-dev (2.7.3-0ubuntu3.1) ...
    Setting up python-dev (2.7.3-0ubuntu2) ...
    Setting up libboost-python1.46-dev (1.46.1-7ubuntu3) ...
    Setting up libboost-python-dev (1.48.0.2) ...
    Setting up libftgl2 (2.1.3~rc5-4) ...
    Setting up libssl-doc (1.0.1-4ubuntu5.5) ...
    Setting up wx2.8-headers (2.8.12.1-6ubuntu2) ...
    Setting up libwxbase2.8-dev (2.8.12.1-6ubuntu2) ...
    update-alternatives: using /usr/lib/i386-linux-gnu/wx/config/base-unicode-release-2.8 to provide /usr/bin/wx-config (wx-config) in auto mode.
    Setting up wx-common (2.8.12.1-6ubuntu2) ...
    Setting up libwxgtk2.8-dev (2.8.12.1-6ubuntu2) ...
    update-alternatives: using /usr/lib/i386-linux-gnu/wx/config/gtk2-unicode-release-2.8 to provide /usr/bin/wx-config (wx-config) in auto mode.
    Setting up libopencascade-foundation-6.5.0 (6.5.0.dfsg-2build1) ...
    Setting up libopencascade-foundation-dev (6.5.0.dfsg-2build1) ...
    Setting up libopencascade-modeling-6.5.0 (6.5.0.dfsg-2build1) ...
    Setting up libopencascade-modeling-dev (6.5.0.dfsg-2build1) ...
    Setting up libopencascade-ocaf-lite-6.5.0 (6.5.0.dfsg-2build1) ...
    Setting up libopencascade-ocaf-lite-dev (6.5.0.dfsg-2build1) ...
    Setting up libopencascade-visualization-6.5.0 (6.5.0.dfsg-2build1) ...
    Setting up libopencascade-ocaf-6.5.0 (6.5.0.dfsg-2build1) ...
    Setting up libopencascade-ocaf-dev (6.5.0.dfsg-2build1) ...
    Setting up libopencascade-visualization-dev (6.5.0.dfsg-2build1) ...
    Setting up libopencascade-dev (6.5.0.dfsg-2build1) ...
    Processing triggers for libc-bin ...
    ldconfig deferred processing now taking place
    nick@NickUbuntu:~$ git clone --recursive git://github.com/Heeks/heekscad.git
    fatal: destination path 'heekscad' already exists and is not an empty directory.
    nick@NickUbuntu:~$ cd heekscad
    nick@NickUbuntu:~/heekscad$ cmake .
    -- Found wxWidgets: TRUE
    CMake Warning at CMakeLists.txt:26 (find_package):
    Could not find module FindOCE.cmake or a configuration file for package
    OCE.

    Adjust CMAKE_MODULE_PATH to find FindOCE.cmake or set OCE_DIR to the
    directory containing a CMake configuration file for OCE. The file will
    have one of the following names:

    OCEConfig.cmake
    oce-config.cmake



    -- Found OCC include dir: /usr/include/opencascade
    -- Found OCC lib dir: /usr/lib
    -- This is a 32-bit system.
    -- Found PythonLibs: /usr/lib/libpython2.7.so
    -- Looking for XOpenDisplay in /usr/lib/i386-linux-gnu/libX11.so;/usr/lib/i386-linux-gnu/libXext.so
    -- Looking for XOpenDisplay in /usr/lib/i386-linux-gnu/libX11.so;/usr/lib/i386-linux-gnu/libXext.so - found
    -- Looking for gethostbyname
    -- Looking for gethostbyname - found
    -- Looking for connect
    -- Looking for connect - found
    -- Looking for remove
    -- Looking for remove - found
    -- Looking for shmat
    -- Looking for shmat - found
    -- Looking for IceConnectionNumber in ICE
    -- Looking for IceConnectionNumber in ICE - found
    -- Found X11: /usr/lib/i386-linux-gnu/libX11.so
    -- Found OpenGL: /usr/lib/i386-linux-gnu/libGL.so
    -- Configuring done
    CMake Error at src/CMakeLists.txt:340 (add_executable):
    Cannot find source file:

    ../libarea/Arc.cpp

    Tried extensions .c .C .c++ .cc .cpp .cxx .m .M .mm .h .hh .h++ .hm .hpp
    .hxx .in .txx


    -- Build files have been written to: /home/nick/heekscad
    nick@NickUbuntu:~/heekscad$ make package
    make: *** No rule to make target `package'. Stop.
    nick@NickUbuntu:~/heekscad$ sudo dpkg -i heekscad_*.deb
    [sudo] password for nick:
    dpkg: error processing heekscad_*.deb (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    heekscad_*.deb
    nick@NickUbuntu:~/heekscad$ sudo dpkg -i heekscad_*.deb
    dpkg: error processing heekscad_*.deb (--install):
    cannot access archive: No such file or directory
    Errors were encountered while processing:
    heekscad_*.deb

  6. #6
    Join Date
    Aug 2012
    Beans
    286

    Re: trying to install HeeksCNC and having trouble (See Pastes from Terminal)

    Any ideas? I'd love to get this working.

  7. #7
    Join Date
    Apr 2012
    Beans
    5,597

    Re: trying to install HeeksCNC and having trouble (See Pastes from Terminal)

    I downloaded it and tried to build it just to see if I could help - basically it appears to be broken, the cmake never generates a makefile (due to the initial FindOCE.cmake error, I think)

    I poked around a bit and found an updated INSTALL_UBUNTU.sh script which the author claimed had fixed the FindOCE.cmake error - but that seemed to be even more broken (didn't even download the source - I tried it again after manually grabbing the git clone and it still failed). Here it is anyway - ymmv

    https://github.com/Heeks/heekscad/pull/11

  8. #8
    Join Date
    Aug 2012
    Beans
    286

    Re: trying to install HeeksCNC and having trouble (See Pastes from Terminal)

    Quote Originally Posted by steeldriver View Post
    I downloaded it and tried to build it just to see if I could help - basically it appears to be broken, the cmake never generates a makefile (due to the initial FindOCE.cmake error, I think)

    I poked around a bit and found an updated INSTALL_UBUNTU.sh script which the author claimed had fixed the FindOCE.cmake error - but that seemed to be even more broken (didn't even download the source - I tried it again after manually grabbing the git clone and it still failed). Here it is anyway - ymmv

    https://github.com/Heeks/heekscad/pull/11
    Thanks Steel! I appreciate you always helping me find what's wrong with these elusive drivers. Still no sound from that Recording Input device or GCode from my DXF drawings but I'm not giving up yet!!! And I still have a dual boot for the time being.

  9. #9
    Join Date
    Sep 2012
    Beans
    1

    Re: trying to install HeeksCNC and having trouble (See Pastes from Terminal)

    I was just trying to install just now and ran into the same problem also.

    A quick read of the installation instructions revealed some dependencies that I was missing which were not explicitly mentioned in the wiki. From your terminal record you are missing this also. You will need to pull the git depository from various sources first on top of heekscad. Follow my instructions instead.

    Run the following from terminal in order:

    sudo apt-get install libopencascade-foundation-6.5.0 libopencascade-modeling-6.5.0 python-wxgtk2.8 libboost-python1.48.0 git subversion cmake build-essential
    git clone git://github.com/Heeks/heekscad.git
    git clone git://github.com/Heeks/heekscnc.git
    git clone git://github.com/Heeks/libarea.git
    git clone git://github.com/aewallin/opencamlib.git
    git clone git://github.com/tpaviot/oce.git
    cd heekscad
    cmake ./
    make
    sudo make install

    this seems to work for me

  10. #10
    Join Date
    Aug 2012
    Beans
    286

    Re: trying to install HeeksCNC and having trouble (See Pastes from Terminal)

    Quote Originally Posted by hugies1 View Post
    I was just trying to install just now and ran into the same problem also.

    A quick read of the installation instructions revealed some dependencies that I was missing which were not explicitly mentioned in the wiki. From your terminal record you are missing this also. You will need to pull the git depository from various sources first on top of heekscad. Follow my instructions instead.

    Run the following from terminal in order:

    sudo apt-get install libopencascade-foundation-6.5.0 libopencascade-modeling-6.5.0 python-wxgtk2.8 libboost-python1.48.0 git subversion cmake build-essential
    git clone git://github.com/Heeks/heekscad.git
    git clone git://github.com/Heeks/heekscnc.git
    git clone git://github.com/Heeks/libarea.git
    git clone git://github.com/aewallin/opencamlib.git
    git clone git://github.com/tpaviot/oce.git
    cd heekscad
    cmake ./
    make
    sudo make install

    this seems to work for me

    This worked until:
    nick@NickUbuntu:~/heekscad$ make
    make: *** No targets specified and no makefile found. Stop.
    nick@NickUbuntu:~/heekscad$
    then this next line did this:
    nick@NickUbuntu:~/heekscad$ sudo make install
    [sudo] password for nick:
    make: *** No rule to make target `install'. Stop.

Page 1 of 2 12 LastLast

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •