Results 1 to 10 of 10

Thread: LightDM doesn't start automatically.

  1. #1
    Join Date
    Mar 2012
    Beans
    48

    LightDM doesn't start automatically.

    When I booted into Ubuntu, it got stuck at the splash screen. However, I was able to the console, meaning the system had started, but lightdm had not. Had I not started lightdm manually from the console, it would have been stuck at the splash screen forever.

    This is my /var/log/boot.log:
    Code:
    fsck from util-linux 2.20.1 
    Ubuntu: clean, 379898/6553600 files, 10754588/26214400 blocks 
    modem-manager[1093]: <info>  ModemManager (version 0.5.2.0) starting... 
      
    modem-manager[1093]: <info>  Loaded plugin Sierra 
      
    modem-manager[1093]: <info>  Loaded plugin Linktop 
      
    modem-manager[1093]: <info>  Loaded plugin MotoC 
      
    modem-manager[1093]: <info>  Loaded plugin Novatel 
      
    modem-manager[1093]: <info>  Loaded plugin Samsung 
      
    modem-manager[1093]: <info>  Loaded plugin Option 
      
    modem-manager[1093]: <info>  Loaded plugin Option High-Speed 
      
    modem-manager[1093]: <info>  Loaded plugin X22X 
      
    modem-manager[1093]: <info>  Loaded plugin Generic 
      
    modem-manager[1093]: <info>  Loaded plugin Ericsson MBM 
      
    modem-manager[1093]: <info>  Loaded plugin Longcheer 
      
    modem-manager[1093]: <info>  Loaded plugin Huawei 
      
    modem-manager[1093]: <info>  Loaded plugin ZTE 
      
    modem-manager[1093]: <info>  Loaded plugin Wavecom 
      
    modem-manager[1093]: <info>  Loaded plugin Gobi 
      
    modem-manager[1093]: <info>  Loaded plugin SimTech 
      
    modem-manager[1093]: <info>  Loaded plugin Nokia 
      
    modem-manager[1093]: <info>  Loaded plugin AnyData 
      
    Skipping profile in /etc/apparmor.d/disable: usr.bin.firefox 
    Skipping profile in /etc/apparmor.d/disable: usr.sbin.rsyslogd 
     * Starting mDNS/DNS-SD daemon[ OK ] 
     * Stopping Mount filesystems on boot[ OK ] 
     * Starting AppArmor profiles         [ OK ] 
    Rather than invoking init scripts through /etc/init.d, use the service(8) 
    utility, e.g. service S20lightdm start 
     * Stopping System V initialisation compatibility[ OK ] 
     * Starting System V runlevel compatibility[ OK ] 
     * Starting automatic crash report generation[ OK ] 
     * Starting restore sound card(s') mixer state(s)[ OK ] 
     * Starting ACPI daemon[ OK ] 
     * Starting save kernel messages[ OK ] 
     * Starting anac(h)ronistic cron[ OK ] 
    initctl: Unknown job: S20lightdm 
     
    Since the script you are attempting to invoke has been converted to an 
    Upstart job, you may also use the start(8) utility, e.g. start S20lightdm 
     * Starting CPU interrupts balancing daemon[ OK ] 
     * Starting crash report submission daemon[ OK ] 
    speech-dispatcher disabled; edit /etc/default/speech-dispatcher 
     * Starting deferred execution scheduler[ OK ] 
     * Starting regular background program processing daemon[ OK ] 
     * Starting VirtualBox kernel modules         [ OK ] 
     * Stopping anac(h)ronistic cron[ OK ] 
     * Stopping save kernel messages[ OK ] 
     * Stopping restore sound card(s') mixer state(s)[ OK ] 
     * Starting the Winbind daemon winbind         [ OK ] 
    saned disabled; edit /etc/default/saned 
     * Stopping cold plug devices[ OK ] 
     * Stopping log initial device creation[ OK ] 
     * Starting load fallback graphics devices[ OK ] 
     * Starting configure virtual network devices[ OK ] 
     * Stopping load fallback graphics devices[ OK ] 
     * Stopping configure virtual network devices[ OK ] 
     * Starting configure network device security[ OK ] 
     * Starting GNOME Display Manager[ OK ] 
     * Starting Userspace bootsplash[ OK ] 
     * Starting anac(h)ronistic cron[ OK ] 
     * Stopping anac(h)ronistic cron[ OK ] 
     * Stopping GNOME Display Manager[ OK ] 
     * Starting LightDM Display Manager[ OK ] 
     * Stopping LightDM Display Manager[ OK ] 
     * Stopping Userspace bootsplash[ OK ] 
     * Checking battery state...         [ OK ] 
     * Stopping System V runlevel compatibility[ OK ] 
     * Starting CUPS printing spooler/server[ OK ] 
     * Starting Mount network filesystems[ OK ] 
     * Stopping Mount network filesystems[ OK ]
    The bold messages show lightdm starting but then stopping again. After that is says it's stopping the splash screen, which never happens.

    Any ideas?

    Don't remember why I looked, but I found out that all the lightdm scripts in /etc/rc*.d have the K20 prefix (which means "disabled", apparently). Maybe this has something to do with it?

  2. #2
    Join Date
    Mar 2012
    Beans
    48

    Re: LightDM doesn't start automatically.

    Fixed it. I installed GDM a few days ago and after removing it, /etc/X11/default-display-manager contained lightdm instead of /usr/sbin/lightdm.

  3. #3
    Join Date
    Feb 2005
    Location
    Melbourne, Australia
    Beans
    13,505
    Distro
    Ubuntu 12.04 Precise Pangolin

    Re: LightDM doesn't start automatically.

    Quote Originally Posted by Splooshie123 View Post
    Fixed it. I installed GDM a few days ago and after removing it, /etc/X11/default-display-manager contained lightdm instead of /usr/sbin/lightdm.
    Then report it as a bug or it may never get fixed.
    Regards, David.
    Please use the Forum search and Wiki search for immediate help
    Please mark your thread as Solved when appropriate
    New to technical forums?: How To Ask Questions The Smart Way

  4. #4
    Join Date
    Apr 2006
    Beans
    4

    Re: LightDM doesn't start automatically.

    This worked for me too. Please do report this a a bug . Only then will this be resolved.

  5. #5
    Join Date
    Aug 2009
    Beans
    3,523
    Distro
    Ubuntu Development Release

    Re: LightDM doesn't start automatically.

    Quote Originally Posted by Splooshie123 View Post
    Fixed it. I installed GDM a few days ago and after removing it, /etc/X11/default-display-manager contained lightdm instead of /usr/sbin/lightdm.
    I guess it is still not fixed.
    This saved me too!
    I installed gdm on Precise and almost lost the ability to get back into it.
    Found where sudo dpkg-reconfigure lightdm would make lightdm work except it didn't.
    Since recovery is to a read only file system I could not do anything there until I found something Paddy Landau had posted on a bug about it.
    He said this was a workaround and it worked:
    Login to recovery and then enter:

    Code:
    mount --options remount,rw /
    mount --all
    So, then I was successfully able to enter sudo dpkg-reconfigure lightdm without getting an error. I also purged gdm.
    But, upon bootup all it would do was have a black screen with 4 dots that turned yellow and would not go past that.
    I discovered I could press ALT+F2 and get the login prompt. Then I could enter sudo service lightdm start and it would finally allow me to login to Precise normally.
    I knew that lightdm was there but, wasn't starting upon bootup.
    That is when I found this thread.
    Editing /etc/X11/default-display-manager saved me! Whew!
    Thank you Splooshie123!
    Check Java Version | Install Java via WEB UPD8 PPA
    Creating a Custom Maintenance Free GRUB2 Screen Community Wiki
    Precise 12.04 | Trusty 14.04 | Vivid 15.04 | Mint Rebecca 17 | Windows 7 | All 64 bit

  6. #6
    Join Date
    Jan 2013
    Beans
    1

    Re: LightDM doesn't start automatically.

    Thank you, helped a lot after some months with starting lightdm by alternate console

  7. #7
    Join Date
    Mar 2012
    Beans
    246

    Re: LightDM doesn't start automatically.

    Heh, i have to admit that i didn't know about this, and the cause of this. It happened to me also - i installed, just like you, gdm, and after that i could not start lightdm even when gdm was purged, also my system, if i was succesful in starting lightdm, was started in low graphic mode - don't know why.

  8. #8
    Join Date
    Aug 2009
    Beans
    3,523
    Distro
    Ubuntu Development Release

    Re: LightDM doesn't start automatically.

    Quote Originally Posted by firekage View Post
    Heh, i have to admit that i didn't know about this, and the cause of this. It happened to me also - i installed, just like you, gdm, and after that i could not start lightdm even when gdm was purged, also my system, if i was succesful in starting lightdm, was started in low graphic mode - don't know why.
    Did you edit /etc/X11/default-display-manager?

    gksudo gedit /etc/X11/default-display-manager
    and make sure it contained /usr/sbin/lightdm and not just lightdm?

    If it gives you read only access enter:
    Code:
    mount --options remount,rw /
    mount --all
    before hand. I had to write this stuff down when I did it.
    Check Java Version | Install Java via WEB UPD8 PPA
    Creating a Custom Maintenance Free GRUB2 Screen Community Wiki
    Precise 12.04 | Trusty 14.04 | Vivid 15.04 | Mint Rebecca 17 | Windows 7 | All 64 bit

  9. #9
    Join Date
    Mar 2012
    Beans
    246

    Re: LightDM doesn't start automatically.

    Quote Originally Posted by Cavsfan View Post
    Did you edit /etc/X11/default-display-manager?

    gksudo gedit /etc/X11/default-display-manager
    and make sure it contained /usr/sbin/lightdm and not just lightdm?

    If it gives you read only access enter:
    Code:
    mount --options remount,rw /
    mount --all
    before hand. I had to write this stuff down when I did it.
    No, i just reinstalled gdm and i've been using it because i didn't know why lightdm doesen;t want to work at all.

    Now i know. Thanks.

  10. #10
    Join Date
    Nov 2013
    Beans
    1

    Re: LightDM doesn't start automatically.

    Hello guys, please help me I'm having the same problem but my /etc/X11/default-display-manager have this line /usr/sbin/lightdm and my lightdm stills not starting automatically... I haven't installed GDM, I think this started to happen after my qShutdown installation...

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •