Results 1 to 3 of 3

Thread: Evince+Code128 Font from internetzollanmeldung.de

Threaded View

  1. #1
    Join Date
    Aug 2012
    Beans
    1

    Evince+Code128 Font from internetzollanmeldung.de

    Hi,

    I am using Ubuntu 12.04.1 LTS with evince 3.4.0. I tried shipping abroad, with

    https://www.ausfuhrplus.internetzollanmeldung.de/iaap/

    at the end of the process you get a pdf.
    This pdf needs a Type1-font called "Code-128" which you can download from the website.
    But the downloaded file contains a TrueType-font (code_128.ttf). So i copied it to

    Code:
    /usr/local/share/fonts/truetype
    and ran

    Code:
    fc-cache -vf
    dpkg-reconfigure fontconfig
    It worked fine for LibreOffice but viewing the pdf with evince still didn't show any barcode. So I tried to convert it using

    Code:
    ttf2ufm code_128.ttf
    and copied the resulting files to

    Code:
    /usr/share/fonts/type1/Code-128
    and ran the shell-commands again. Still evince didn't recognize the fonts.
    When I run
    Code:
    fc-cache -vf
    I get
    Code:
    ...
    /usr/share/fonts/type1/Code-128: caching, new cache contents: 1 fonts, 0 dirs
    ...
    Other pdf-viewer like epdfview, okular, xpdf, ... also don't recognize the font.

    What am I missing?

    How can I use that font?
    Last edited by hagos; August 20th, 2012 at 02:45 PM. Reason: Typo

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •