Results 1 to 3 of 3

Thread: Logitech wireless mouse started freezing when inactive and not connected to AC power

  1. #1
    Join Date
    Jul 2007
    Beans
    17

    Logitech wireless mouse started freezing when inactive and not connected to AC power

    (Ubuntu 11.10, 3.0.0-14-generic x86-64, Sony Vaio VPCZ13, Logitech M180 Wireless mouse)

    Recently my mouse has started freezing when using the laptop battery. After not moving the mouse for a couple of seconds, when I try to move the mouse, it takes a second or two for it to start moving. Before, there was no lag at all (and there still isn't in the Other Operating System).

    This is what appears in the syslog during the freeze:


    Jan 13 12:26:30 hw-vaio kernel: [ 574.336797] ehci_hcd 0000:00:1d.0: BAR 0: set to [mem 0xb6427800-0xb6427bff] (PCI address [0xb6427800-0xb6427bff])
    Jan 13 12:26:30 hw-vaio kernel: [ 574.336821] ehci_hcd 0000:00:1d.0: restoring config space at offset 0xf (was 0x100, writing 0x10a)
    Jan 13 12:26:30 hw-vaio kernel: [ 574.336849] ehci_hcd 0000:00:1d.0: restoring config space at offset 0x1 (was 0x2900000, writing 0x2900002)
    Jan 13 12:26:30 hw-vaio kernel: [ 574.336915] ehci_hcd 0000:00:1d.0: PME# disabled
    Jan 13 12:26:30 hw-vaio kernel: [ 574.336930] ehci_hcd 0000:00:1d.0: PCI INT A -> GSI 20 (level, low) -> IRQ 20
    Jan 13 12:26:30 hw-vaio kernel: [ 574.336939] ehci_hcd 0000:00:1d.0: setting latency timer to 64
    Jan 13 12:26:30 hw-vaio kernel: [ 574.352768] ehci_hcd 0000:00:1a.0: BAR 0: set to [mem 0xb6427c00-0xb6427fff] (PCI address [0xb6427c00-0xb6427fff])
    Jan 13 12:26:30 hw-vaio kernel: [ 574.352790] ehci_hcd 0000:00:1a.0: restoring config space at offset 0xf (was 0x100, writing 0x10b)
    Jan 13 12:26:30 hw-vaio kernel: [ 574.352817] ehci_hcd 0000:00:1a.0: restoring config space at offset 0x1 (was 0x2900000, writing 0x2900002)
    Jan 13 12:26:30 hw-vaio kernel: [ 574.352883] ehci_hcd 0000:00:1a.0: PME# disabled
    Jan 13 12:26:30 hw-vaio kernel: [ 574.352895] ehci_hcd 0000:00:1a.0: PCI INT A -> GSI 23 (level, low) -> IRQ 23
    Jan 13 12:26:30 hw-vaio kernel: [ 574.352903] ehci_hcd 0000:00:1a.0: setting latency timer to 64
    Jan 13 12:26:30 hw-vaio kernel: [ 574.352931] ehci_hcd 0000:00:1a.0: PCI INT A disabled
    Jan 13 12:26:30 hw-vaio kernel: [ 574.352976] ehci_hcd 0000:00:1a.0: PME# enabled
    What I've tried so far:

    Older kernels (-13 & -12), removing recent installs.

    There's nothing to my eye in my /var/log/apt/term.log that reeks like the culprit:

    Setting up firefox-globalmenu (9.0.1+build1-0ubuntu0.11.10.2) ...
    Setting up xul-ext-mozvoikko (1.10.0-0ubuntu2.2) ...
    Setting up firefox-gnome-support (9.0.1+build1-0ubuntu0.11.10.2) ...
    Setting up firefox-locale-fi (9.0.1+build1-0ubuntu0.11.10.2) ...
    Setting up mozvoikko (1.10.0-0ubuntu2.2) ...
    Setting up xul-ext-ubufox (1.0.2-0ubuntu0.11.10.1) ...
    Setting up compiz-plugins-main-default (1:0.9.6-0ubuntu4.2) ...
    Setting up compiz-plugins-main (1:0.9.6-0ubuntu4.2) ...
    And earlier:

    Setting up sysvinit-utils (2.88dsf-13.10ubuntu4.1) ...
    Setting up sysv-rc (2.88dsf-13.10ubuntu4.1) ...
    Setting up initscripts (2.88dsf-13.10ubuntu4.1) ...
    Installing new version of config file /etc/init.d/sendsigs ...
    Installing new version of config file /etc/init.d/umountroot ...
    Setting up libwebkitgtk-1.0-common (1.4.3-0ubuntu4) ...
    Setting up libwebkitgtk-1.0-0 (1.4.3-0ubuntu4) ...
    Setting up banshee (2.2.1-1ubuntu3) ...
    Setting up banshee-extension-soundmenu (2.2.1-1ubuntu3) ...
    Setting up banshee-extension-ubuntuonemusicstore (2.2.1-1ubuntu3) ...
    Setting up binutils (2.21.53.20110810-0ubuntu5.1) ...
    Setting up libwebkitgtk-3.0-common (1.4.3-0ubuntu4) ...
    Setting up libwebkitgtk-3.0-0 (1.4.3-0ubuntu4) ...
    Setting up gir1.2-webkit-3.0 (1.4.3-0ubuntu4) ...
    Setting up gnome-shell (3.2.1-0ubuntu1.1) ...
    Setting up python-ubuntuone-client (2.0.0-0ubuntu2.3) ...
    Setting up ubuntuone-client (2.0.0-0ubuntu2.3) ...
    Setting up libsyncdaemon-1.0-1 (2.0.0-0ubuntu2.3) ...
    Setting up unity-services (4.24.0-0ubuntu2.1) ...
    Setting up libunity-core-4.0-4 (4.24.0-0ubuntu2.1) ...
    Setting up unity-common (4.24.0-0ubuntu2.1) ...
    Setting up unity (4.24.0-0ubuntu2.1) ...
    Setting up unity-lens-applications (0.4.12-0ubuntu2.1) ...
    Setting up unity-place-applications (0.4.12-0ubuntu2.1) ...
    And even earlier (very improbable that it happened after this update):

    Setting up banshee (2.2.1-1ubuntu2) ...
    Setting up banshee-extension-soundmenu (2.2.1-1ubuntu2) ...
    Setting up banshee-extension-ubuntuonemusicstore (2.2.1-1ubuntu2) ...
    Setting up libjasper1 (1.900.1-7ubuntu2.11.10.1) ...
    Setting up libgs9-common (9.04~dfsg-0ubuntu11.4) ...
    Setting up libgs9 (9.04~dfsg-0ubuntu11.4) ...
    Setting up ghostscript (9.04~dfsg-0ubuntu11.4) ...
    Setting up ghostscript-x (9.04~dfsg-0ubuntu11.4) ...
    Setting up libjasper1:i386 (1.900.1-7ubuntu2.11.10.1) ...
    Setting up ghostscript-cups (9.04~dfsg-0ubuntu11.4) ...
    Setting up libarchive1 (2.8.4-1ubuntu0.11.10.1) ...
    Setting up libgweather-common (3.2.0-0ubuntu1.1) ...
    Setting up libgweather-3-0 (3.2.0-0ubuntu1.1) ...
    Setting up libt1-5 (5.1.2-3ubuntu0.11.10.1) ...
    Setting up software-center (5.0.3.1) ...
    Any ideas what to do? I'd be really grateful for any tips!

    And yeah, I tried changing the mouse battery too. Didn't help.

  2. #2
    Join Date
    Nov 2004
    Location
    Austin, TX... for now
    Beans
    117
    Distro
    Ubuntu

    Re: Logitech wireless mouse started freezing when inactive and not connected to AC po

    I had this problem, and traced it back to having installed the laptop-mode-tools. Uninstalling it reverted the behavior back to normal. I have no idea which script in laptop-mode-tools causes the ACPI fluctuation but it sure was annoying.

  3. #3
    Join Date
    Jul 2007
    Beans
    17

    Re: Logitech wireless mouse started freezing when inactive and not connected to AC po

    Thanks for the reply, WorLord! I haven't encountered this problem since installing 12.04, but I don't actually remember (and don't have the laptop handy) if I've installed laptop-mode-tools or not.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •