I have a Dlink DWA-556 pci express wireless card that uses AR5418 Wireless Network Adapter [AR5008E 802.11(a)bgn] (PCI-Express).

This card works in the older ubuntu kernel 3.0.17 but it does not in the newer kernels and certainly not in the 3.2.0.29 - SAME MACHINE!

Here is the
Code:
dmesg | grep ath
output for 3.2.0.29

[ 11.047317] ath9k 0000:01:00.0: Refused to change power state, currently in D3
[ 11.047326] ath9k 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 11.150910] ath: Couldn't reset chip
[ 11.150913] ath: Unable to initialize hardware; initialization status: -5
[ 11.150916] ath9k 0000:01:00.0: Failed to initialize device
[ 11.150937] ath9k 0000:01:00.0: PCI INT A disabled
[ 11.150942] ath9k: probe of 0000:01:00.0 failed with error -5
And the same for the older 3.0.17-030017-generic kernel
[ 17.547883] ath9k 0000:01:00.0: PCI INT A -> GSI 16 (level, low) -> IRQ 16
[ 17.547891] ath9k 0000:01:00.0: setting latency timer to 64
[ 17.681297] ath: EEPROM regdomain: 0x10
[ 17.681299] ath: EEPROM indicates we should expect a direct regpair map
[ 17.681301] ath: Country alpha2 being used: CO
[ 17.681302] ath: Regpair used: 0x10
[ 17.736460] ieee80211 phy0: Selected rate control algorithm 'ath9k_rate_control'
[ 17.736852] Registered led device: ath9k-phy0
I can give any other info you want, but the above seems to say it all.

When I boot into the newer kernel, network manager or 'lshw -C network' does not even show the wireless interface.

Any ideas? Thanks for your help.