Results 1 to 4 of 4

Thread: ACER TravelMate B113: Howto get everything to work

Threaded View

  1. #1
    Join Date
    Jun 2012
    Beans
    42

    Lightbulb ACER TravelMate B113: Howto get everything to work

    Hey there!
    As I bought a new Acer TravelMate B113 for my girlfriend and I ran into some issues, here is what I figured out:

    Issues after a clean install:
    1) Fn-Brightness and Ubuntu internal brightness do not work
    2) No powersaving optimizations
    3) No proper right click support for clickpad and no proper palm detection
    4) No external support microphone or combined headset-plugs

    Solutions:

    1) Fn-Brightness and Ubuntu internal brightness do not work:

    Add
    Code:
    acpi_backlight=vendor
    to /etc/default/grub in the section GRUB_CMDLINE_LINUX_DEFAULT="quiet splash acpi_backlight=vendor" and execute
    Code:
    sudo update-grub && sudo reboot
    .

    2) No powersaving optimizations:

    Again, edit /etc/default/grub and add
    Code:
    pcie_aspm=force i915.i915_enable_fbc=1 drm.vblankoffdelay=1 i915.semaphores=1 i915.lvds_downclock=1 nmi_watchdog=0 acpi_backlight=vendor
    in the section GRUB_CMDLINE_LINUX_DEFAULT="quiet splash pcie_aspm=force i915.i915_enable_fbc=1 drm.vblankoffdelay=1 i915.semaphores=1 i915.lvds_downclock=1 nmi_watchdog=0 acpi_backlight=vendor" and execute this:
    Code:
    sudo update-grub && sudo reboot
    Execute this to get ALPM to work:

    Code:
    echo SATA_ALPM_ENABLE=true | sudo tee /etc/pm/config.d/sata_alpm
    Create /etc/udev/rules.d/10-runtime-pm.rules with root permission:
    Code:
    SUBSYSTEM!="pci", GOTO="power_runtime_rules_end"
    ACTION!="add", GOTO="power_runtime_rules_end"
    
    KERNEL=="????:??:??.?"
    PROGRAM="/bin/sleep 0.1"
    
    ATTR{power/control}=="*", ATTR{power/control}="auto"
    
    LABEL="power_runtime_rules_end"

    3) No proper right click support for clickpad:

    Create a a new folder and a new file:
    Code:
    sudo mkdir /etc/X11/xorg.conf.d/ && sudo nano /etc/X11/xorg.conf.d/51-clickpad.conf
    Paste this into your new file:
    Code:
    Section "InputClass
    Identifier "Default clickpad buttons"
    MatchDriver "synaptics"
    Option "SoftButtonAreas" "50% 0 82% 0 0 0 0 0"
    
    EndSection
    Execute this in a terminal once and never enable the setting "System Settings > Mouse & Touchpad > Touchpad > Disable touchpad while typing" again:
    Code:
    gsettings set org.gnome.settings-daemon.peripherals.touchpad disable-while-typing false
    Add a new entry to your startup programs, on Unity desktop it can be done this way:
    Run "System Settings > Startup Applications > Add" and add
    Code:
    syndaemon -i 1.7 -d -t -K
    You might want to edit the value -i 1.7, as it defines how long tapping would be disabled after stopping typing in seconds.
    Needs a reboot to take effect.

    4) No external support microphone or combined headset-plugs:

    Type this into a terminal:

    Code:
    echo options snd-hda-intel model=laptop-dmic | sudo tee -a /etc/modprobe.d/alsa-base.conf


    Thats it!
    Everything else seems to works out of the box.
    Last edited by nexero; August 13th, 2012 at 09:39 AM.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •