Results 1 to 4 of 4

Thread: Mono

  1. #1
    Join Date
    Aug 2012
    Beans
    2

    Mono

    Hi,

    I'm trying to install mono/monodevelop on my 12.04 but it's not working, monodevelop says that I don't have the nunit framework. The problem is that I do have the nunit framework for CLI installed but it seems that monodevelop doesn't see it. Does anyone know what are the steps to follow to make it working.

    Thanks a lot for you help

  2. #2
    Join Date
    May 2012
    Beans
    289
    Distro
    Ubuntu Development Release

    Re: Mono

    Post the output of the following command(s):
    Code:
    sudo apt-get update && sudo apt-get -s install monodevelop-nunit monodevelop

  3. #3
    Join Date
    Aug 2012
    Beans
    2

    Re: Mono

    Thanks Lyfang,

    I've found a solution, I changed the target framework of my project from .Net 3.5 to .Net 4.0 and now it works... Now I have to understand why

  4. #4
    Join Date
    Oct 2006
    Location
    /dev/null
    Beans
    1,574
    Distro
    Ubuntu 10.04 Lucid Lynx

    Re: Mono

    Quote Originally Posted by ozooo View Post
    Thanks Lyfang,

    I've found a solution, I changed the target framework of my project from .Net 3.5 to .Net 4.0 and now it works... Now I have to understand why
    .NET 4.0 is the only supported version in Ubuntu 11.10 and higher - all libraries on the system are built only for 4.0
    Understanding is a three-edged sword: Your side, their side, and the truth

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •