Results 1 to 6 of 6

Thread: lxpanel not at the edge of screen

  1. #1
    Join Date
    Mar 2009
    Location
    Cerulean City
    Beans
    49
    Distro
    Ubuntu 13.04 Raring Ringtail

    lxpanel not at the edge of screen

    When I log into Lubuntu now, the panel isn't all the way at the top of the screen. There's a screenshot here. This has been happening since I started using multiple monitors on my system, but it happens every time I login, even if the second monitor is not plugged in/turned off.
    I can get it back to the top by setting it to the bottom edge and then the top again, but I have to this each time I login. Any idea why this would happen/how I can fix it?

  2. #2
    Join Date
    Jun 2007
    Location
    Arizona, USA
    Beans
    223
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: lxpanel not at the edge of screen

    It's getting late here, and I've had a long day. So I won't be able to offer troubleshooting tips, but can point you here: http://pclosmag.com/html/Issues/201010/page07.html where there are plenty of details covering how to configure LXPanel.

    Good luck!
    The future will soon be a thing of the past.

  3. #3
    Join Date
    Mar 2009
    Location
    Cerulean City
    Beans
    49
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: lxpanel not at the edge of screen

    Thanks for the link, but it doesn't look like my problem is really addressed in there. The panel is set to display at the top, it's just not all the way there for some reason. It's getting late here as well, maybe someone in a different time zone will find something before morning

  4. #4
    Join Date
    Apr 2010
    Location
    Hungary
    Beans
    71
    Distro
    Ubuntu 12.10 Quantal Quetzal

    Re: lxpanel not at the edge of screen

    Hi,
    check out this website: http://wiki.lxde.org/en/LXPanel
    Search your config file (in ~/.config/lxpanel/LXDE) for the line like this:

    Code:
    margin=0       # margin: margin to the edge of the whole screen
    maybe there could be some mistake, what makes your panel act funny

  5. #5
    Join Date
    Dec 2008
    Location
    Northwest Ohio
    Beans
    1,581
    Distro
    Lubuntu 13.10 Saucy Salamander

    Re: lxpanel not at the edge of screen

    If this is caused by lxpanel starting too quickly then this link should help:

    Delay lxpanel autostart in Lubuntu
    http://ubuntuforums.org/showthread.php?t=2024713

  6. #6
    Join Date
    Mar 2009
    Location
    Cerulean City
    Beans
    49
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: lxpanel not at the edge of screen

    Unfortunately, I tried both of those and no success :/ . That last one gave me an idea, and when starting lxpanel with the Lubuntu profile, even after all other programs are loaded, it does not go completely to the top of the screen. It actually looks as if the space being reserved for the panel is actually being avoided by the panel itself
    EDIT: My own post just helped me! Woo! I just had to click the "make window managers treat panel as dock" option and voila, it places itself correctly now. Thanks everyone for your suggestions, they all at least helped me understand LXDE a bit better.
    Last edited by smitty96; July 22nd, 2012 at 05:11 AM. Reason: fixed!

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •