Results 1 to 8 of 8

Thread: FTP mount using gigolo opens in Firefox instead of thunar

  1. #1
    Join Date
    Jun 2008
    Beans
    79

    FTP mount using gigolo opens in Firefox instead of thunar

    I am recently having an annoying issue with Gigolo. When I connect to an ftp share on my local network, double clicking on the mounted folder in Gigolo opens the share in firefox. I want to be able to use Thunar to see the share. Does anyone know how I can fix this?

  2. #2
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: FTP mount using gigolo opens in Firefox instead of thunar

    In gigolo, under Edit->Preferences, what do you have in the "File Manager" text-box?

    EDIT: And what does the following return:
    Code:
    xdg-mime query default x-scheme-handler/ftp
    Last edited by Toz; July 20th, 2012 at 03:14 PM.

  3. #3
    Join Date
    Dec 2009
    Beans
    5,304

    Re: FTP mount using gigolo opens in Firefox instead of thunar

    I don't mean to turn this into a blog entry but I tried a double click in gigolo and it too opened up Firefox.

    I tried Toz's command which resulted in:
    > xdg-mime query default x-scheme-handler/ftp
    > exo-web-browser.desktop
    That made sense but I didn't know what to do with that information but I figured an exo-file-manager.desktop would fix it. I tried to do that in /usr/share/applications ( defaults.list & mimeinfo.cache ) but was not successful so what I did was this:
    Code:
    leafpad $HOME/.local/share/applications/mimeapps.list
    And under [Default Applications] added the following line:
    Code:
    x-scheme-handler/ftp=exo-file-manager.desktop
    Saved the file, double clicked the gigolo ftp entry and it opened Thunar.

    Seems kind of silly to do this by user instead of globally and no doubt I'm supposed to run an update command or something to make the change in the global settings but I can't figure it out.
    Last edited by Morbius1; July 20th, 2012 at 07:52 PM.

  4. #4
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: FTP mount using gigolo opens in Firefox instead of thunar

    Hi Morbius1.
    To make the change globally on Xubuntu, the file to edit is /usr/share/xubuntu/applications/defaults.list. There is an existing entry there for x-scheme-handler/ftp which points it to exo-web-browser.desktop

  5. #5
    Join Date
    Dec 2009
    Beans
    5,304

    Re: FTP mount using gigolo opens in Firefox instead of thunar

    Quote Originally Posted by Toz View Post
    Hi Morbius1.
    To make the change globally on Xubuntu, the file to edit is /usr/share/xubuntu/applications/defaults.list. There is an existing entry there for x-scheme-handler/ftp which points it to exo-web-browser.desktop
    Ah, Didn't even realize there was a /usr/share/xubuntu/applications - I'll have to give it a go. Thanks.

    So is the priority order on this thing:
    $HOME/.local/share/applications
    /usr/share/xubuntu/application
    /usr/share/application

    Where the one in one's home directory takes precedence above all others and the one in /usr/share/xubuntu over the one in /usr/share/appliction?

  6. #6
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: FTP mount using gigolo opens in Firefox instead of thunar

    Yes. /usr/share/xubuntu/applications/defaults.list comes from the xubuntu-default-settings package, but I don't see how its setup in the system to take precedence over /usr/share/applications/defaults.list - it just does.

  7. #7
    Join Date
    Dec 2009
    Beans
    5,304

    Re: FTP mount using gigolo opens in Firefox instead of thunar

    I don't know if kpuz is getting anything out of this but I for one appreciate the information

  8. #8
    Join Date
    Jun 2005
    Location
    Toronto, Canada
    Beans
    Hidden!
    Distro
    Xubuntu Development Release

    Re: FTP mount using gigolo opens in Firefox instead of thunar

    Good point.

    @kupz, to summarize:

    To fix the problem for your specific user account, add the following:
    Code:
    x-scheme-handler/ftp=exo-file-manager.desktop
    ...to the end of $HOME/.local/share/applications/mimeapps.list

    To fix it globally for all users, edit /usr/share/xubuntu/applications/defaults.list as root:
    Code:
    sudo leafpad /usr/share/xubuntu/applications/defaults.list
    and change the line:
    x-scheme-handler/ftp=exo-web-browser.desktop
    ...to read:
    Code:
    x-scheme-handler/ftp=exo-file-manager.desktop
    ...and save the file.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •