Results 1 to 5 of 5

Thread: Cannot install new packages

  1. #1
    Join Date
    Feb 2011
    Beans
    5

    Cannot install new packages

    I'm running Ubuntu 11.10, on a System 76 computer.

    I've been having issues for the past few months, where I'm unable to install any new packages using synaptic:

    Code:
    ~ sudo apt-get install abe
    ...
    Code:
    dpkg: error: read error in `/var/lib/dpkg/triggers//File': Input/output error
    E: Sub-process /usr/bin/dpkg returned an error code (2)
    I get similar errors with the following:

    Code:
    ~ sudo dpkg --configure -a
    [sudo] password for jack: 
    dpkg: error: read error in `/var/lib/dpkg/triggers//File': Input/output error
    Using update manager returns the same errors.

    Thanks in advance.

  2. #2
    Join Date
    Feb 2011
    Beans
    5

    Re: Cannot install new packages

    Following things I have tried:

    Code:
    sudo apt-get autoclean
    sudo apt-get clean 
    sudo apt-get update
    sudo apt-get upgrade
    No success.
    Last edited by JackWM; May 12th, 2012 at 06:52 AM. Reason: Clarity

  3. #3
    Join Date
    Jan 2012
    Beans
    133
    Distro
    Ubuntu 13.04 Raring Ringtail

    Re: Cannot install new packages

    Try these

    sudo apt-get --purge autoremove
    sudo apt-get update
    sudo apt-get upgrade

  4. #4
    Join Date
    Feb 2011
    Beans
    5

    Re: Cannot install new packages

    Quote Originally Posted by MustafaJF View Post
    Try these

    sudo apt-get --purge autoremove
    sudo apt-get update
    sudo apt-get upgrade
    Code:
    ~ sudo apt-get --purge autoremove 
    [sudo] password for jack: 
    Reading package lists... Done
    Building dependency tree       
    Reading state information... Done
    0 upgraded, 0 newly installed, 0 to remove and 1599 not upgraded.
    Code:
    Fetched 486 MB in 37min 40s (215 kB/s)                                         
    Extracting templates from packages: 100%
    Preconfiguring packages ...
    dpkg: error: read error in `/var/lib/dpkg/triggers//File': Input/output error
    E: Sub-process /usr/bin/dpkg returned an error code (2)
    Same error as I was getting before.

    Thanks for your help, this has been troubling me for the past month or so.
    Do you have any more ideas?
    Last edited by JackWM; May 12th, 2012 at 08:30 AM. Reason: Spelling correction

  5. #5
    Join Date
    Feb 2011
    Beans
    5

    Re: Cannot install new packages

    I've also tried:

    Code:
    ~ sudo apt-get -f install
    ~ sudo apt-get update
    ~ sudo apt-get upgrade
    Which gives the usual error:

    Code:
    dpkg: error: read error in `/var/lib/dpkg/triggers//File': Input/output error
    E: Sub-process /usr/bin/dpkg returned an error code (2)

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •