Results 1 to 4 of 4

Thread: Capitel 3G CDMA EVDO Modem not working in 12.04

  1. #1
    Join Date
    Jul 2008
    Location
    India
    Beans
    29
    Distro
    Ubuntu 9.10 Karmic Koala

    Capitel 3G CDMA EVDO Modem not working in 12.04

    I use a Capitel 3G EVDO USB CDMA modem (device id - 1c9e:9e00)to connect to the internet. In previous versions of Ubuntu, 11.10, 11.04, 10.10, when I plugged the modem into the USB port, after brief time Network Manager would list it in the Network Manager list as Configure New CDMA modem and the I could configure the modem with its username and password and use it normally.
    After I installed Ubuntu 12.04 Precise, the modem is probably detected because it does show up as Omega Technology, device id ic9e:9e00, when I type 'lsusb' in the terminal. But Network Manager does not display the modem in its list even after a long period of time. If I try to create a new Mobile Broadband connection, the new connection dialog box does not display any supported device.
    This is a somewhat widespread problem of 3G modems not being detected with Ubuntu 12.04, whereas it worked perfectly well with the previous versions and apparently there is no clear solution to it yet.

  2. #2
    Join Date
    Oct 2009
    Location
    A world without windows
    Beans
    Hidden!

    Re: Capitel 3G CDMA EVDO Modem not working in 12.04

    Hi

    Can post results of these commands from the terminal , remember to post only those lines which pertain to the device
    Code:
    echo SYSTEM_BIT=$($(which getconf) LONG_BIT)
    Code:
    nm-tool
    Code:
    ls -al /dev/serial/by-id
    Code:
    usb-devices
    there is a script here for testing modem-manger , using d-bus , not sure it will work in 12.04 , but worth a shot ,
    #62
    Last edited by alexfish; May 4th, 2012 at 10:10 AM.
    Two tin cans are better than an iphone

    http://www.ehow.co.uk/how_2067160_ma...hone.html?cr=1

  3. #3
    Join Date
    Sep 2011
    Beans
    2

    Re: Capitel 3G CDMA EVDO Modem not working in 12.04

    I had the same problem and found a workaround here:

    http://askubuntu.com/questions/12685...modem-micromax

    hth

  4. #4
    Join Date
    Jul 2008
    Location
    India
    Beans
    29
    Distro
    Ubuntu 9.10 Karmic Koala

    Re: Capitel 3G CDMA EVDO Modem not working in 12.04

    Quote Originally Posted by alexfish View Post
    Hi

    Can post results of these commands from the terminal , remember to post only those lines which pertain to the device
    Code:
    echo SYSTEM_BIT=$($(which getconf) LONG_BIT)
    Code:
    nm-tool
    Code:
    ls -al /dev/serial/by-id
    Code:
    usb-devices
    there is a script here for testing modem-manger , using d-bus , not sure it will work in 12.04 , but worth a shot ,
    #62
    Dear alexfish, sorry for trying this out so late.
    I followed your suggested solution on this thread http://ubuntuforums.org/showthread.php?t=1969322 and now the modem gets detected and listed in Network Manager. From there I can create a new CDMA modem connection and configure the username and password to be used with the connection. It works fine and connects to the net.
    Thank you so much for the solution.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •