Results 1 to 6 of 6

Thread: Netgear N300 driver no wlan on Precise 12.04

  1. #1
    Join Date
    May 2012
    Beans
    13

    Netgear N300 driver no wlan on Precise 12.04

    Hi,
    I have been searching forums and trying various solutions for days, but I am still having no luck - hopefully someone can help me!

    I have 12.04 server edition with the gnome gui and webmin. I am currently connected to the internet using ethernet. I have a Netgear wireless USB adapter (WNDA3100) which I understand uses the Broadcom 43xx driver.

    I have used ndiswrapper to install the driver and I can see both the driver and hardware.

    Code:
    ali@BrownServer:/$ ndiswrapper -l
    bcmn43xx32 : driver installed
    	device (0846:9011) present
    Code:
    ali@BrownServer:/$ lsusb
    Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
    Bus 002 Device 001: ID 1d6b:0001 Linux Foundation 1.1 root hub
    Bus 001 Device 010: ID 0846:9011 NetGear, Inc. WNDA3100v2 802.11abgn [Broadcom BCM4323]
    Bus 002 Device 002: ID 413c:2005 Dell Computer Corp. RT7D50 Keyboard
    Bus 002 Device 003: ID 046d:c018 Logitech, Inc. Optical Wheel Mouse
    Bus 001 Device 006: ID 1058:0702 Western Digital Technologies, Inc. Passport External HDD
    Code:
    ali@BrownServer:/$ iwconfig
    lo        no wireless extensions.
    
    eth0      no wireless extensions.
    Can anyone point me in the right direction?

  2. #2
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,426
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Netgear N300 driver no wlan on Precise 12.04

    Are there any interesting messages here?
    Code:
    dmesg | grep ndis
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  3. #3
    Join Date
    May 2012
    Beans
    13

    Re: Netgear N300 driver no wlan on Precise 12.04

    Yes, it appears there is some interesting stuff!

    Code:
    ali@BrownServer:~$ dmesg | grep ndis
    [   15.042858] ndiswrapper version 1.57 loaded (smp=yes, preempt=no)
    [   16.383200] ndiswrapper (check_nt_hdr:141): kernel is 64-bit, but Windows driver is not 64-bit;bad magic: 010B
    [   16.383225] ndiswrapper (load_sys_files:199): couldn't prepare driver 'bcmn43xx32'
    [   16.383464] ndiswrapper (load_wrap_driver:121): couldn't load driver 'bcmn43xx32'
    [   16.383634] usbcore: registered new interface driver ndiswrapper
    [  661.207001] ndiswrapper (check_nt_hdr:141): kernel is 64-bit, but Windows driver is not 64-bit;bad magic: 010B
    [  661.207015] ndiswrapper (load_sys_files:199): couldn't prepare driver 'bcmn43xx32'
    [  661.207209] ndiswrapper (load_wrap_driver:121): couldn't load driver 'bcmn43xx32'
    [ 1524.931647] ndiswrapper (check_nt_hdr:141): kernel is 64-bit, but Windows driver is not 64-bit;bad magic: 010B
    [ 1524.931661] ndiswrapper (load_sys_files:199): couldn't prepare driver 'bcmn43xx32'
    [ 1524.931867] ndiswrapper (load_wrap_driver:121): couldn't load driver 'bcmn43xx32'
    [ 3086.404408] usbcore: deregistering interface driver ndiswrapper
    Have tried both 32 bit and 63 bit drivers, but I think the 64 bit version might have been a bit funny in the download.

    Hmmmm. Any thoughts on next steps?

  4. #4
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,426
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Netgear N300 driver no wlan on Precise 12.04

    kernel is 64-bit, but Windows driver is not 64-bit;bad magic: 010B
    You might uninstall it:
    sudo ndiswrapper -e bcmn43xx32
    And then try the 64-bit .inf file here.

    You might also read post #14 here: http://ubuntuforums.org/showthread.p...wlhigh5&page=2

    Also post #28 here: http://ubuntuforums.org/showthread.php?t=1946875&page=3

    bcmn43xx32 and -64 are slight variations of bcmwlhigh5.inf.
    Attached Files Attached Files
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

  5. #5
    Join Date
    May 2012
    Beans
    13

    Re: Netgear N300 driver no wlan on Precise 12.04

    Ok, that didn't work.
    Code:
    ali@BrownServer:~$ ndiswrapper -l
    bcmn43xx64 : invalid driver!
    I gather from your other threads that you haven't really come across a solution for this yourself. I take it I can't use the 32bit driver on my 64bit server install either?

    Hmmm. Guess I'm stuck with ethernet for the time being.

  6. #6
    Join Date
    Aug 2005
    Location
    South Carolina, USA
    Beans
    19,426
    Distro
    Ubuntu 14.04 Trusty Tahr

    Re: Netgear N300 driver no wlan on Precise 12.04

    I take it I can't use the 32bit driver on my 64bit server install either?
    No.
    I gather from your other threads that you haven't really come across a solution for this yourself.
    Not for 64-bit. I can get a 32-bit PAE kernel to work just fine.
    Chili's Folly: Intel NUC, i3-4010U, 120 GB SSD, 16 GB RAM, external 500 GB HDD, Ubuntu Saucy; small, silent and fast.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •