Results 1 to 8 of 8

Thread: Only detecting dual monitor (HDMI) during boot

  1. #1
    Join Date
    Apr 2012
    Beans
    11

    Only detecting dual monitor (HDMI) during boot

    This is a very odd problem I've gotten into. When I boot my laptop with a second monitor connected through HDMI, it shows a clone of the image on my laptop (a flashing underscore, that is) but when it arrives at the login screen my TV suddenly says "No Signal" and when I go to Preferences -> Monitor Settings there is no second monitor.

    Also, I have another problem. I would love to run XBMC and use the magnificent GUI on my TV (which is why I'm trying to use dual screens in the first place) but when I try to load XBMC it says: XBMC needs hardware accelerated OpenGL rendering. Install an appropriate graphics driver. I don't have any driver install as of now that I'm aware of. Choosing ATI/AMD proprietary FGLRX graphics driver in Preferences -> Additional Drivers didn't resolve the XBMC problem nor the dual monitor problem.

    The laptop has ATI Mobility Radeon HD 4330.

    Any suggestions?

  2. #2
    Join Date
    Apr 2012
    Beans
    11

    Re: Only detecting dual monitor (HDMI) during boot

    Gah. I must've been tired when I started this thread. Totally wrong forum category.

    Mod, please move to correct category.

  3. #3
    Join Date
    Apr 2012
    Beans
    11

    Re: Only detecting dual monitor (HDMI) during boot

    Ok, I'll gill you a absolutely awesome guitar solo:

    Maybe someone who's into speed metal will answer, I don't know. I'm just frustrated.

  4. #4
    Join Date
    Apr 2012
    Beans
    11

    Re: Only detecting dual monitor (HDMI) during boot

    Not much I can do bot Google around, but I don't find any appropriate guides. I've managed to install xserver-xorg-core at least, and now I can access XBMC. But HDMI is still not being recognized. I downloaded this tool called disper and when I run disper -l this is what I get:

    display LVDS1: LVDS1
    resolutions: 640x480, 800x600, 1024x768, 1360x768, 1366x768

    As you can see only one monitor is in this list, even though I have my TV connected through HDMI and it works for about 10 seconds during startup (showing blinking underscore than returns to "No Signal").

    So, how do I active this TV and why isn't it listed under "Monitor Settings" or in disper?

  5. #5
    Join Date
    Jul 2011
    Location
    Lubuntu One Stop Group
    Beans
    Hidden!
    Distro
    Lubuntu

    Re: Only detecting dual monitor (HDMI) during boot

    did you check amd catalyst control center?

  6. #6
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Only detecting dual monitor (HDMI) during boot

    Hi, please post the output of

    Code:
    xrandr
    And if you want, try a quick fix-

    Code:
    xrandr --output HDMI1 --auto
    GNU/Linux Notes || Linux Command Line Learning Resources

    Copy.com offers 15 GB free cloud storage plus 5 GB for both of us when you follow this referral link.

  7. #7
    Join Date
    Apr 2012
    Beans
    11

    Re: Only detecting dual monitor (HDMI) during boot

    Quote Originally Posted by cortman View Post
    Hi, please post the output of

    Code:
    xrandr
    And if you want, try a quick fix-

    Code:
    xrandr --output HDMI1 --auto
    I haven't had an internet connection for some time, so here comes my 3 week old answer:

    Like I said earlier the computer doesn't detect the TV at all:

    nosredna@nosredna-acer:~$ xrandr
    Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
    LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
    1366x768 60.0*+
    1360x768 59.8 60.0
    1024x768 60.0
    800x600 60.3 56.2
    640x480 59.9
    VGA1 disconnected (normal left inverted right x axis y axis)
    DP1 disconnected (normal left inverted right x axis y axis)

    nosredna@nosredna-acer:~$ xrandr --output HDMI1 --auto
    warning: output HDMI1 not found; ignoring

  8. #8
    Join Date
    Oct 2011
    Location
    ZZ9 Plural Z Alpha
    Beans
    Hidden!
    Distro
    Lubuntu 12.10 Quantal Quetzal

    Re: Only detecting dual monitor (HDMI) during boot

    Quote Originally Posted by nosredna View Post
    [B]nosredna@nosredna-acer:~$ xrandr
    Screen 0: minimum 320 x 200, current 1366 x 768, maximum 8192 x 8192
    LVDS1 connected 1366x768+0+0 (normal left inverted right x axis y axis) 345mm x 194mm
    1366x768 60.0*+
    1360x768 59.8 60.0
    1024x768 60.0
    800x600 60.3 56.2
    640x480 59.9
    VGA1 disconnected (normal left inverted right x axis y axis)
    DP1 disconnected (normal left inverted right x axis y axis)
    This would point to a graphics driver problem. Are you sure you're using the fglrx proprietary ATI drivers? Are you using the catalyst control center as was advised earlier?
    If so, it could be that it simply doesn't work. ATI cards have historically given problems, and this thread doesn't seem very optimistic.
    GNU/Linux Notes || Linux Command Line Learning Resources

    Copy.com offers 15 GB free cloud storage plus 5 GB for both of us when you follow this referral link.

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •