Results 1 to 10 of 21

Thread: Korean input with Nabi ****

Threaded View

  1. #1
    Join Date
    Aug 2005
    Location
    Seoul, Korea
    Beans
    39
    Distro
    Ubuntu 7.10 Gutsy Gibbon

    Korean input with Nabi ****

    This is how to get Korean input working within Dapper - Gnome,
    using nabi as the input method.

    Step 1

    you need to install the packages nabi and im-switch.
    Code:
    sudo apt-get install nabi im-switch
    Step 2

    You will need to setup the environment for gnome to use nabi.
    Start by creating a file in your home directory named .gnomerc
    Code:
    gedit ~/.gnomerc
    Copy and paste the following into the file.
    Code:
    export XMODIFIERS="@im=nabi"
    export XIM_PROGRAM=/usr/bin/nabi
    export GTK_IM_MODULE=xim
    export QT_IM_MODULE=xim
    nabi &
    Save the file

    Step 3

    Tell im-switch to use nabi
    Code:
    im-switch -s nabi
    Now restart the x-server by pressing {Ctrl}-{Alt}-{Backspace}

    If you recieve and error (in Korean) or your nabi box is blank all of
    the time then your locale setting needs to be changed to a korean
    locale or a utf-8 compatible one
    eg. en_AU.UTF-8

    The button to switch between English/Korean is {shift}-{Space}
    You can select other buttons by right clicking the Nabi tray Icon
    selecting preferences and then the hangul tab followed by {+add}
    I chose the evil windows button as my input switcher (take that ms)
    Last edited by mikwig; June 29th, 2006 at 06:08 AM.

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •