Page 1 of 2 12 LastLast
Results 1 to 10 of 12

Thread: close lid do nothing fail

  1. #1
    Join Date
    Dec 2008
    Beans
    27
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    close lid do nothing fail

    Hi everyone,

    With 12.04 out and the much awaited increased support for multiple monitors, I was stoked to finally be able to use my TV as my monitor and essentially "dock" my laptop with an external KVM (not a switch, just USB for the keyboard and mouse, HDMI for the tv.

    Now, onto the issue. I have the power settings for lid close set to do nothing while on AC. With the lid open, everything works fine and the video feed gets sent to my TV. However, when I close the lid to tuck it away, I lose the feed to my TV. Opening the lid back up prompts me for my password, indicating that it did not "do nothing." What, if anything, am I doing wrong here?

    Thanks in advance
    SELECT * FROM Users WHERE clue > 0;
    no results found

    Quoth the server, "404".

  2. #2
    Join Date
    Feb 2011
    Location
    Maryland
    Beans
    2,251

    Re: close lid do nothing fail

    Can you check the lights on your computer to see if its going to sleep? It sounds like even though you set it not to, its happening anyways

  3. #3
    Join Date
    Dec 2008
    Beans
    27
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: close lid do nothing fail

    It looks like it does as the fan turns off. However, when i unplug the HDMI cable and close the lid, it stays active.
    SELECT * FROM Users WHERE clue > 0;
    no results found

    Quoth the server, "404".

  4. #4
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,686
    Distro
    Ubuntu Development Release

    Re: close lid do nothing fail

    Hi

    Monitor power saving ? Have you played with dpms ?

    Open a terminal and type

    Code:
    xset -dpms
    Then close the lid. Any change ?

    Kind regards
    Join us on irc at #ubuntuforums. For web chat see here

    If you believe everything you read, you better not read. ~ Japanese Proverb

    Do not read newspapers on an empty stomach ~ Russian Proverb ~ BrunoLotse

  5. #5
    Join Date
    Dec 2008
    Beans
    27
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: close lid do nothing fail

    No change
    SELECT * FROM Users WHERE clue > 0;
    no results found

    Quoth the server, "404".

  6. #6
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,686
    Distro
    Ubuntu Development Release

    Re: close lid do nothing fail

    Hi

    Did you disable the screen saver lock screen ? Not sure if that's the problem but worth checking.

    Can we also check the settings. Open a terminal and type
    Code:
    gsettings  list-recursively | grep power
    Post the results back here.

    Kind regards
    Join us on irc at #ubuntuforums. For web chat see here

    If you believe everything you read, you better not read. ~ Japanese Proverb

    Do not read newspapers on an empty stomach ~ Russian Proverb ~ BrunoLotse

  7. #7
    Join Date
    Dec 2008
    Beans
    27
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: close lid do nothing fail

    No change. What's throwing me off is that the settings work fine as long as I dont have my HDMI cable plugged in. When it's in, my computer screen is off and the TV is on, just as I need. Once the lid closes, the computer locks. When the HDMI cable is unplugged, the proper settings are applied and the computer does not lock.

    On a side issue, and not very important at this time but might be related, the sound output remains with the laptop speakers and does not go to the TV.
    SELECT * FROM Users WHERE clue > 0;
    no results found

    Quoth the server, "404".

  8. #8
    Join Date
    May 2010
    Location
    Tewkesbury uk
    Beans
    7,686
    Distro
    Ubuntu Development Release

    Re: close lid do nothing fail

    Hi

    The last command posted was to see what your settings are, not to set anything.

    Can you rerun the command again and post the results back in your next post.

    Kind regards
    Join us on irc at #ubuntuforums. For web chat see here

    If you believe everything you read, you better not read. ~ Japanese Proverb

    Do not read newspapers on an empty stomach ~ Russian Proverb ~ BrunoLotse

  9. #9
    Join Date
    Dec 2008
    Beans
    27
    Distro
    Ubuntu 9.04 Jaunty Jackalope

    Re: close lid do nothing fail

    My apologies. it looked it like was setting the power properties to a profile.


    com.canonical.indicator.power icon-policy 'present'
    com.canonical.indicator.power show-time true
    org.gnome.power-manager info-history-graph-points true
    org.gnome.power-manager info-history-graph-smooth true
    org.gnome.power-manager info-history-time 21600
    org.gnome.power-manager info-history-type 'charge'
    org.gnome.power-manager info-last-device ''
    org.gnome.power-manager info-page-number 0
    org.gnome.power-manager info-stats-graph-points true
    org.gnome.power-manager info-stats-graph-smooth true
    org.gnome.power-manager info-stats-type 'discharge-accuracy'
    org.gnome.rhythmbox.plugins active-plugins ['artdisplay', 'audiocd', 'audioscrobbler', 'cd-recorder', 'daap', 'dbus-media-server', 'generic-player', 'ipod', 'iradio', 'mmkeys', 'mpris', 'mtpdevice', 'notification', 'power-manager']
    org.gnome.settings-daemon.plugins.power active true
    org.gnome.settings-daemon.plugins.power button-hibernate 'hibernate'
    org.gnome.settings-daemon.plugins.power button-power 'interactive'
    org.gnome.settings-daemon.plugins.power button-sleep 'suspend'
    org.gnome.settings-daemon.plugins.power button-suspend 'suspend'
    org.gnome.settings-daemon.plugins.power critical-battery-action 'hibernate'
    org.gnome.settings-daemon.plugins.power idle-brightness 30
    org.gnome.settings-daemon.plugins.power idle-dim-ac false
    org.gnome.settings-daemon.plugins.power idle-dim-battery true
    org.gnome.settings-daemon.plugins.power idle-dim-time 30
    org.gnome.settings-daemon.plugins.power lid-close-ac-action 'nothing'
    org.gnome.settings-daemon.plugins.power lid-close-battery-action 'nothing'
    org.gnome.settings-daemon.plugins.power notify-perhaps-recall true
    org.gnome.settings-daemon.plugins.power percentage-action 2
    org.gnome.settings-daemon.plugins.power percentage-critical 3
    org.gnome.settings-daemon.plugins.power percentage-low 10
    org.gnome.settings-daemon.plugins.power priority 1
    org.gnome.settings-daemon.plugins.power sleep-display-ac 1800
    org.gnome.settings-daemon.plugins.power sleep-display-battery 1800
    org.gnome.settings-daemon.plugins.power sleep-inactive-ac-timeout 0
    org.gnome.settings-daemon.plugins.power sleep-inactive-ac-type 'suspend'
    org.gnome.settings-daemon.plugins.power sleep-inactive-battery-timeout 3600
    org.gnome.settings-daemon.plugins.power sleep-inactive-battery-type 'suspend'
    org.gnome.settings-daemon.plugins.power time-action 120
    org.gnome.settings-daemon.plugins.power time-critical 300
    org.gnome.settings-daemon.plugins.power time-low 1200
    org.gnome.settings-daemon.plugins.power use-time-for-policy true
    SELECT * FROM Users WHERE clue > 0;
    no results found

    Quoth the server, "404".

  10. #10
    Join Date
    Aug 2009
    Beans
    12

    Re: close lid do nothing fail

    I am effected by this as well.

    Possible workaround: In System Settings > Brightness and Lock switch off 'Lock'. The downside is that your system also cannot lock anymore after a set time.

Page 1 of 2 12 LastLast

Tags for this Thread

Bookmarks

Posting Permissions

  • You may not post new threads
  • You may not post replies
  • You may not post attachments
  • You may not edit your posts
  •